XHTML+MathML file causes Firefox 3.0.1 to Hang

RESOLVED FIXED in mozilla1.9.1b1

Status

()

Core
MathML
--
critical
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Shlomi Fish, Assigned: karlt)

Tracking

1.9.0 Branch
mozilla1.9.1b1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072110 Mandriva/3.0.1-1mdv2009.0 (2009.0) Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072110 Mandriva/3.0.1-1mdv2009.0 (2009.0) Firefox/3.0.1

When browsing to the URL in question, Firefox 3.0.1 completely hangs and this is without any extensions.

Reproducible: Always

Steps to Reproduce:
1. Browse to the URL.
2.
3.
Actual Results:  
Firefox hangs.

Expected Results:  
Firefox should display the page.

Mandriva Cooker Linux - Firefox 3.0.1 from either the Mandriva sources or the binary Linux package from getfirefox.com.
No hang on Windows XP so it might be Linux only.
Works for me, Firefox 3.0.1 on Kubuntu 8.04

Comment 3

9 years ago
WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1 on Debian GNU/Linux lenny/sid.
(Reporter)

Comment 4

9 years ago
I was now able to reproduce it with a new user account running the vanilla Firefox 3.0.1 on IceWM. I'll report this bug to the Mandriva Bug-tracker. Stay Tuned.

Regards,

       Shlomi Fish

Comment 5

9 years ago
Works fine for me with Firefox trunk on Mac.
Component: General → MathML
Product: Firefox → Core
QA Contact: general → mathml
Version: unspecified → 1.9.0 Branch
(Reporter)

Comment 6

9 years ago
Here is the report on the Mandriva Bugzilla:

https://qa.mandriva.com/show_bug.cgi?id=42317
(Assignee)

Comment 7

9 years ago
Likely related to bug 404857.

strace -e trace=file -p <firefox-bin-process-id> may be interesting.
Depends on: 404857
(Assignee)

Updated

9 years ago
Assignee: nobody → mozbugz
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 8

9 years ago
Changes in bug 404857 should have fixed this.
Target Milestone: --- → mozilla1.9.1b1
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.