Last Comment Bug 448453 - Caldav Calenders working with 0.8 don't load under 0.9pre
: Caldav Calenders working with 0.8 don't load under 0.9pre
Status: RESOLVED FIXED
: relnote
Product: Calendar
Classification: Client Software
Component: Provider: CalDAV (show other bugs)
: unspecified
: All All
: -- normal (vote)
: 0.9
Assigned To: Bruno Browning
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-29 16:18 PDT by Benjamin Close
Modified: 2008-10-08 05:47 PDT (History)
3 users (show)
dbo.moz: blocking‑calendar0.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
ensure trailing slash on initial PROPFIND (1.21 KB, patch)
2008-07-30 00:09 PDT, Bruno Browning
philipp: review+
Details | Diff | Splinter Review

Description Benjamin Close 2008-07-29 16:18:57 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Lightning 0.9pre Build 2008072818

I have apple caldav server setup running on FreeBSD. I use this to store all my calendars. Under Lighting 0.8 I could view each of my calendars. Under 0.9pre the calendars don't apear. The error reported is multiple of:

Warning: There has been an error reading data for calendar: CIS.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_NOT_DAV. Description: The resource at http://calendar.clearchain.com/calendars/users/benjsc/CIS is either not a DAV collection or not available

I understand debugging remote calendars is hard so please email me direct and I'll give the developer assigned to this bug username/pass and access to server logs for debugging.

Reproducible: Always

Steps to Reproduce:
1. Setup calendar to above address
2. Deinstall lightning 0.8
3. Install lighting 0.9pre 
4. Start thunderbird
Actual Results:  
The calendars show up in the left column (ie remembers there is calendars) however no data about the calendars is displayed

Expected Results:  
The data for the calendar is usable
Comment 1 Bruno Browning 2008-07-29 18:29:23 PDT
I can take a look at this. 
Comment 2 Benjamin Close 2008-07-29 18:53:53 PDT
Login details provided to Bruno
Comment 3 Bruno Browning 2008-07-30 00:09:13 PDT
Created attachment 331706 [details] [diff] [review]
ensure trailing slash on initial PROPFIND

The patch in bug 447913 left us doing the initial PROPFIND against the user-supplied calendar URL, without ensuring that it had a trailing slash. CalendarServer reacts poorly to calendar URLs lacking a trailing slash.
Comment 4 Philipp Kewisch [:Fallen] 2008-07-30 22:06:36 PDT
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Comment 5 Benjamin Close 2008-07-31 17:08:04 PDT
Repeating with the latest nightly confirms the fix is successful - Thanks!
You folk have done a nice job since 0.8 - looks and works great!
Comment 6 Maxime Delorme 2008-08-04 03:28:16 PDT
Don't work for me
the build 2008073119 can not get my events
the build 2008072919 can get my events

with Davical
Comment 7 Maxime Delorme 2008-08-04 03:28:56 PDT
on 2008073119 I get the error DAV_NOT_DAV ....
Comment 8 Bruno Browning 2008-08-04 04:10:17 PDT
(In reply to comment #6)
> Don't work for me
> the build 2008073119 can not get my events
> the build 2008072919 can get my events
> 
> with Davical
> 

That 31 July build does work for me with current davical, on Linux. Any chance you could turn on two prefs calendar.debug.log and calendar.debug.log.verbose and report what you see in the error console?
Comment 9 Maxime Delorme 2008-08-04 04:41:28 PDT
(In reply to comment #8)
CalDAV: Status 207 on initial PROPFIND for calendar mdelorme
CalDAV: Authentication scheme Basic
CalDAV: recv: <?xml version="1.0" encoding="utf-8" ?>
<multistatus xmlns="DAV:">
 <response>
  <href>/cal/mdelorme/home/</href>
  <propstat>
   <prop>
    <resourcetype>
     <collection/>
     <calendar xmlns="urn:ietf:params:xml:ns:caldav"/>
    </resourcetype>
    <HTTP://CALENDARSERVER.ORG/NS/:GETCTAG/>
   </prop>
   <status>HTTP/1.1 200 OK</status>
  </propstat>
 </response>
</multistatus>
Avertissement : There has been an error reading data for calendar: mdelorme.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_NOT_DAV. Description: The resource at https://www.tennaxia.net/cal/mdelorme/home/ is either not a DAV collection or not available
Avertissement : There has been an error reading data for calendar: mdelorme.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: 
Comment 10 Bruno Browning 2008-08-04 04:49:59 PDT
[In reply to comment #9]
This looks like a DAViCal problem parsing the getctag query. On my DAViCal setup the getctag part of that response looks like

  <propstat>
   <prop>
    <C1:getctag/>
   </prop>
   <status>HTTP/1.1 404 Not Found</status>
  </propstat>

... whereas yours just repeats back the query. What version of DAViCal are you using?


Comment 11 Maxime Delorme 2008-08-04 05:05:07 PDT
0.9.1
Comment 12 Bruno Browning 2008-08-04 05:11:58 PDT
... and mine is 0.9.5  IMO the remaining problem here is a DAViCal one rather than a Sunbird/Lightning one. Is it possible for you to upgrade?
Comment 13 Maxime Delorme 2008-08-04 05:56:59 PDT
Unfortunately The upgrade is not planned, so I can't upgrade 
Comment 14 Bruno Browning 2008-08-04 20:15:24 PDT
Since we're working with the current version of DAViCal, I'm going to go ahead and re-close this bug. Will suggest a relnote about interop issues with older versions of DAViCal. Sorry for your trouble, Maxime; hope they will plan an upgrade soon.

->FIXED
Comment 15 Simon Paquet [:sipaq] 2008-08-28 02:41:57 PDT
Bruno, I need a good descriptive relnote-text for this bug (see comment 14). 

Any suggestions?
Comment 16 Bruno Browning 2008-08-28 03:20:48 PDT
(In reply to comment #15)
> Bruno, I need a good descriptive relnote-text for this bug (see comment 14). 
> 
> Any suggestions?
> 

I'd suggest something along the lines of "There are interoperability issues with versions of DAViCal (RSCDS) prior to 0.9.5. People using earlier releases of DAViCal are advised to stay with Sunbird/Lightning 0.8 until they can upgrade their DAViCal to the current version."
Comment 17 Mark van Beek 2008-10-08 05:47:12 PDT
We have the same issue within our company and discovered we can work around it by renewing the calendars, only this time as an iCal calendar! Until we didn't find any  problems...

Note You need to log in before you can comment on or make changes to this bug.