xlink:href linking in MathML regressed

VERIFIED DUPLICATE of bug 427990

Status

()

Core
MathML
VERIFIED DUPLICATE of bug 427990
10 years ago
10 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Build ID: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/2008072802 Minefield/3.1a2pre

As of Firefox 3, Simple XLink href-based links no longer work in MathML.

Steps to reproduce:
 1) Load http://www.nag.co.uk/numeric/FL/manual/xhtml/C06/c06eaf.xml 
 2) Click the red letters *inside formulas* (outside formulas they are regular <a href> links)

Actual results:
Nothing happens.

Expected results:
Expected scrolling to the fragment identifier target.

Additional info:
Per bug 332773 general XLink support should be dropped, but support for existing MathML content requires href in the XLink namespace on elements from the MathML namespace to be treated as link.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 427990
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.