The default bug view has changed. See this FAQ.

Firefox improperly names html file type "Firefox Document"

RESOLVED FIXED in Firefox 10

Status

()

Firefox
Installer
--
trivial
RESOLVED FIXED
9 years ago
6 years ago

People

(Reporter: Gary X., Assigned: Javi Rueda)

Tracking

unspecified
Firefox 10
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16

After you make Firefox the default browser on a Windows PC, any file with ".htm" or ".html" extension is listed as file type "Firefox Document" in Windows Explorer.

Well HTML is not a proprietary format owned by Firefox. It is a standard and well known document format, and Firefox just happens to be one agent capable of rendering it. There is no such type as "Firefox document".

Internet Explorer is behaves much better in this regard. If you make IE the default browser, html files are listed as type "HTML Document", which is what they are.

Reproducible: Always

Steps to Reproduce:
1. Make FF the default system browser
2. Go to Windows Explore and view the Detail listing of a directory containing a file with .html extension

Actual Results:  
html file is listed as type "Firefox Document"

Expected Results:  
html file should be listed as "HTML document"
I see this too, but I am not sure if it would be INVALID or not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Shell Integration → Installer
QA Contact: shell.integration → installer
This is not invalid, this is a minor issue with the way Firefox registers its file handling in Windows.

The name can be changed, obviously.
(Assignee)

Comment 3

6 years ago
Google Chrome also changes the description of the filetype. I have not tested Opera but assuming it does it too. I think the same: file type is "HTML Document" whatever program is associated with it.
(Assignee)

Comment 4

6 years ago
My proposed patch is:

In:

http://mxr.mozilla.org/mozilla-central/source/browser/installer/windows/nsis/shared.nsh#292

and

http://mxr.mozilla.org/mozilla-central/source/browser/installer/windows/nsis/shared.nsh#512

Replace "${AppRegName}" with "HTML"
(Assignee)

Comment 5

6 years ago
Created attachment 559563 [details] [diff] [review]
Patch for bug 448717
Assignee: nobody → leofigueres
Attachment #559563 - Flags: review?(robert.bugzilla)
(Assignee)

Updated

6 years ago
Attachment #559563 - Flags: review?(robert.bugzilla) → review?(jmathies)

Comment 6

6 years ago
Comment on attachment 559563 [details] [diff] [review]
Patch for bug 448717

I think we want it named this way, but I should default to rob strong as I'm sure he knows the history behind it. Switching reviewers.
Attachment #559563 - Flags: review?(jmathies) → review?(robert.bugzilla)
Comment on attachment 559563 [details] [diff] [review]
Patch for bug 448717

iirc this was name Firefox Document historically. I don't have a problem with this change but I kind of want UX's input on this since it does show up in Windows UI.

btw: Just took a look at Chrome and it uses Chrome HTML Document.

faaborg, just wanted to get your ok for this change and the patch author should be able to provide you with additional info such as what parts of the Windows UI this text displays in. Thanks
Attachment #559563 - Flags: ui-review?(faaborg)
I'm not sure if this was considered all that carefully to begin with, but the one UX aspect is that we want users to have an expectation of what application is currently associated, and will be used by default to open the document.  I recommend we go with:

Firefox HTML Document

that way the user both knows what kind of document it is (if they want to use the "open with" context command, and what application is currently the default).

One could argue that obfuscating who is the system default is in some ways more nefarious than pretending to take ownership of an open format (not that we meant to do that intentionally).
And it becomes more so when another application registers itself for opening the HTML files but does not change the name.
(Assignee)

Comment 10

6 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #7)
> Comment on attachment 559563 [details] [diff] [review] [diff] [details] [review]
> Patch for bug 448717
> 
> iirc this was name Firefox Document historically. I don't have a problem
> with this change but I kind of want UX's input on this since it does show up
> in Windows UI.
> 
> btw: Just took a look at Chrome and it uses Chrome HTML Document.
> 
In this case, Chrome does it, but Internet Explorer doesn't.

> faaborg, just wanted to get your ok for this change and the patch author
> should be able to provide you with additional info such as what parts of the
> Windows UI this text displays in. Thanks


The text is displayed as a description for the file type in the Windows Explorer. Also it is shown at the Open/Save file dialogs in some views (as the "Detailed" one).
(In reply to Javi Rueda from comment #10)
> (In reply to Robert Strong [:rstrong] (do not email) from comment #7)
> > Comment on attachment 559563 [details] [diff] [review] [diff] [details] [review] [diff] [details] [review]
> > Patch for bug 448717
> > 
> > iirc this was name Firefox Document historically. I don't have a problem
> > with this change but I kind of want UX's input on this since it does show up
> > in Windows UI.
> > 
> > btw: Just took a look at Chrome and it uses Chrome HTML Document.
> > 
> In this case, Chrome does it, but Internet Explorer doesn't.
Right

> > faaborg, just wanted to get your ok for this change and the patch author
> > should be able to provide you with additional info such as what parts of the
> > Windows UI this text displays in. Thanks
> 
> 
> The text is displayed as a description for the file type in the Windows
> Explorer. Also it is shown at the Open/Save file dialogs in some views (as
> the "Detailed" one).
faaborg would like to change it to Firefox HTML Document per comment #8
Comment on attachment 559563 [details] [diff] [review]
Patch for bug 448717

minusing per comment #8 from faaborg
Attachment #559563 - Flags: ui-review?(faaborg)
Attachment #559563 - Flags: review?(robert.bugzilla)
Attachment #559563 - Flags: review-
(Assignee)

Comment 13

6 years ago
Created attachment 567186 [details] [diff] [review]
Patch for bug 448717

Replaces the branded "Document" with the branded "HTML Document".
Attachment #559563 - Attachment is obsolete: true
Attachment #567186 - Flags: review?(robert.bugzilla)
Attachment #567186 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 14

6 years ago
Thank you for the review, Robert.
Keywords: checkin-needed
No problem Javi and thanks for the patch and your patience with me finishing the review!
http://hg.mozilla.org/integration/mozilla-inbound/rev/a4d50bd80534
Keywords: checkin-needed
Target Milestone: --- → Firefox 10
https://hg.mozilla.org/mozilla-central/rev/a4d50bd80534
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.