aElt is null after customize toolbar drag and drop actions

RESOLVED FIXED in mozilla1.9.3a4

Status

()

Toolkit
Toolbars and Toolbar Customization
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Noah, Assigned: dao)

Tracking

unspecified
mozilla1.9.3a4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/2008080203 Firefox/3.0
Build Identifier: 

Open the customize toolbar dialog, drag a separator, for example to the bookmarks toolbar, to the far left before/in front of that toolbar. But don't drop it there, continue holding your mouse click then drag it back to the customize panel, hit done and see if any errors are in the error console.

I get: Error: aElt is null
Source File: chrome://global/content/customizeToolbar.js
Line: 680

I guess it could be happening if I hover over the very very edge of the toolbox during that process. No addons btw.

Reproducible: Always
The error happens here and seems to be Windows only.

function isCustomizableToolbar(aElt)
{
=> return aElt.localName == "toolbar" &&
          aElt.getAttribute("customizable") == "true";
}
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'm still seeing (what I think is) the same error with 3.6 (release) on Vista.

STR:
1 - start with fresh profile
2 - only add-on is Console2 (add it through add-ons mgr search and install, turn off a bunch of nasty plugins, restart)
3 - configure Console2 to show all errors
4 - right-click toolbox to customize
5 - reposition customize window so the full tabstrip is exposed (not covered by customize window)
6 - slowly drag location bar down from #nav-bar toward customize window
7 - while still dragging, as the cursor crosses from the toolbox into the tabstrip area, the error message is displayed
7 - while still dragging, if you wiggle the mouse around that border, or even find the right spot and hold it there, you'll generate a continuous stream of the same error

Error: aElt is null
Source file: chrome://global/content/customizeToolbar.js
Line: 671

Same code as before, at different line now:

function isCustomizableToolbar(aElt)
{
=> return aElt.localName == "toolbar" &&
          aElt.getAttribute("customizable") == "true";
}

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
One of 525258 and this bug is a dupe of the other; calling the other a dupe since this one was filed first.
Duplicate of this bug: 525258
CCing Dao for awareness
(Assignee)

Updated

8 years ago
Assignee: nobody → dao
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 6

8 years ago
Created attachment 433335 [details] [diff] [review]
patch

The dragover event listener is added to the toolbox, but the toolbox isn't necessarily completely filled with toolbars. It can have a bottom padding, for instance, depending on the theme.
Attachment #433335 - Flags: review?(enndeakin)

Updated

8 years ago
Attachment #433335 - Flags: review?(enndeakin) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/ae8e9a478541
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a4
You need to log in before you can comment on or make changes to this bug.