LoginManagerStorage_legacy shouldn't write file if no data present

RESOLVED FIXED in mozilla1.9.1a1

Status

()

Toolkit
Password Manager
--
minor
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: zpao, Assigned: zpao)

Tracking

Trunk
mozilla1.9.1a1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Right now this is blocking bug #288040 - on import from legacy storage of a new profile where no legacy storage files exist, an empty file will be created.  This is not expected behavior. Since this is really a bug with the legacy module, it was spun off into a new bug.

Expected behavior: no file is created
Actual behavior: signons3.txt is created
Comment on attachment 332263 [details] [diff] [review]
Patch v0.1

>-            this.log("Creating new signons file...");
>-            this._writeFile();
>+            this.log(this._signonsFile.path + " does not exist, not creating...");

The path is already logged a few lines up, so this can just be short "no existing file found" message. I"ll fix on commit.
Attachment #332263 - Flags: review?(dolske) → review+
Pushed changeset de6fc723c05b
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1a1
You need to log in before you can comment on or make changes to this bug.