Remove dead libsec function declarations

RESOLVED FIXED in 3.12.1

Status

NSS
Libraries
P3
normal
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: Julien Pierre, Assigned: Julien Pierre)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.51 KB, patch
Nelson Bolyard (seldom reads bugmail)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

9 years ago
I stumbled on some dead code while investigating something else. I will attach a patch to remove it.
(Assignee)

Updated

9 years ago
Priority: -- → P3
(Assignee)

Comment 1

9 years ago
Created attachment 332288 [details] [diff] [review]
Remove dead code

These functions only have declarations, but no definitions, and are ifdef'ed out. There is no reason to keep them in the source.
Attachment #332288 - Flags: review?(nelson)
Comment on attachment 332288 [details] [diff] [review]
Remove dead code

Julien, this file contains a large block that is ifdef'ed out with 
#ifdef notdef.
This patch removes about 80% of the declarations in that ifdef'ed 
block.  Why not remove it all?
(Assignee)

Comment 3

9 years ago
When I looked at it, it seemed that the other functions that I left in still exist somewhere else. But now that you point this out, it appears these declarations are not necessary. I am OK with removing the whole block.
Comment on attachment 332288 [details] [diff] [review]
Remove dead code

Please remove the whole #ifdef notdef block. Thanks.
Attachment #332288 - Flags: review?(nelson) → review+
(Assignee)

Comment 5

9 years ago
Thanks, Nelson. I removed the ifdef block on the trunk.

Checking in certdb/certdb.h;
/cvsroot/mozilla/security/nss/lib/certdb/certdb.h,v  <--  certdb.h
new revision: 1.21; previous revision: 1.20
done
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 341009
You need to log in before you can comment on or make changes to this bug.