Closed Bug 449272 Opened 12 years ago Closed 11 years ago

Google Maps not zoomed correctly on page load

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

x86
macOS
defect
Not set
critical

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0b1
Tracking Status
fennec 1.0+ ---

People

(Reporter: mfinkle, Unassigned)

References

Details

(Keywords: qablocker)

Attachments

(1 file)

Navigate to http://maps.google.com

The page seems too small, like it is over zoomed.
it looks like it is laying out how I would expect for a browser window of 800x480 (or smaller) -- we really want to use a fixed size browser element that is bigger
Target Milestone: --- → Fennec A3
tracking-fennec: --- → 1.0+
Duplicate of this bug: 479042
Assignee: nobody → webapps
Upon inspecting the DOM, Google Maps is programmatically setting a div's height.  It looks like window's innerWidth and innerHeight may be reported incorrectly.
It's because the zoom level is not even close to 1, due to all of the extra white space on the right.  Roy's resizing after load patch might fix this.
Assignee: webapps → nobody
Attached image screenshot of n810
This is happening on builds:

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2b1pre) Gecko/20090924
Fennec/1.0b4pre

and

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20090924
Fennec/1.0b4pre


and i've attached screenshots with the behavior.
By the way, this is not a normal bug. It's critical in severity.
Severity: normal → critical
Confirmed that this is because we were not updating browser w/h after load using Roy's patch https://bug480958.bugzilla.mozilla.org/attachment.cgi?id=402528 and a little tweaking.  Adding dependency.
Depends on: 480958
It definitely looks different after bug 480958 landed. This bug was only about the way the page loaded, not the panning of google maps. The page looks good when loaded now. Agreed?
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
I'm not seeing a change on any of my devices on builds:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2b1pre) Gecko/20091022 Fennec/1.0a4pre

and

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091022
Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20091022
Fennec/1.0b5pre


Mark backed out the patch last night, so that makes sense.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: qablocker
http://hg.mozilla.org/mobile-browser/rev/3d8f7d7b2fc7 fixes this for me
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b2pre) Gecko/20091104 Firefox/3.6b2pre Fennec/1.0b5

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091104 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
Component: General → Panning/Zooming
You need to log in before you can comment on or make changes to this bug.