Last Comment Bug 449391 - shockwave (for director) content becomes transparent and background of web page shows through
: shockwave (for director) content becomes transparent and background of web pa...
Status: VERIFIED FIXED
: shockwave
Product: Plugins Graveyard
Classification: Graveyard
Component: Shockwave (Adobe) (show other bugs)
: unspecified
: All All
-- major
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://staff.explorelearning.com/pfaf...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-06 06:49 PDT by Raman Pfaff
Modified: 2016-04-28 09:13 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Raman Pfaff 2008-08-06 06:49:40 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

While running shockwave content containing interactive content (such as buttons, sliders, etc.) parts of it will become invisible (or transparent) and the background color will "cover" the shockwave content, so it does not display in a reasonable fashion.

Reproducible: Always

Steps to Reproduce:
1. Load shockwave content that is interactive. Click on buttons, checkboxes, etc. Click on the html page (a non-shockwave region).
2. Resize the window of the browser. The content will reappear.
Actual Results:  
Portions of the content become invisible. Just the background color appears.

Expected Results:  
Shockwave content should display correctly.

This is easily reproducible on both OSX (10.5) and the current release of Vista on a PC, and has been seen by other Shockwave developers.

I recall seeing this problem when 2.0 was first released (but can't be 100% sure about that), which was fixed in a point release. This problem is still present in the latest nightly build.

More content can be observed at explorelearning.com (you can view anything for up to 5 minutes).
Comment 1 User image Raman Pfaff 2008-08-06 10:58:06 PDT
Note: Vastly harder to reproduce on Windows.
Comment 2 User image Steven Michaud [:smichaud] (Retired) 2008-08-21 17:08:42 PDT
I can reproduce this in FF 3.0.1 on OS X (10.5.4), but not on Windows
(XP).

In both cases I installed and tested with the current version
(11.0.0r465 on OS X and 11.0 on Windows) of the Shockwave plugin (from
Adobe).

I can't reproduce this in FF 2 on either OS X or Windows XP.

Since comment #0 says this can be seen on Windows, marking "All"
... at least for the time being.
Comment 3 User image Raman Pfaff 2010-01-21 10:04:00 PST
Although I've only done limited testing, this bug may have been fixed in 3.6.0 that was released earlier today.
Comment 4 User image Raman Pfaff 2010-01-22 07:36:10 PST
Looks like the problem is not entirely gone yet. Seems much better than the entire 3.0-3.5.x line though.
Comment 5 User image Yuhong Bao 2010-06-18 22:27:07 PDT
Shockwave 11.5.7.609 was released, and it is reported that this bug is fixed. Can this bug be closed?
Comment 6 User image Raman Pfaff 2010-06-22 12:38:36 PDT
Yes, the problem went away with FF 3.6+ combined with SW 11.5.7.609+. I'll mark this as resolved, although I'm not sure if I really have "power" for something like that.

At least it got fixed ;)
Comment 7 User image timeless 2010-06-29 02:12:28 PDT
for plugins, if the vendor claims to have fixed the bug then yes we're happy w/ FIXED, and if a reporter or someone else can confirm that the problem is resolved, then we're happy w/ VERIFIED.

Thanks for confirming :)

Note You need to log in before you can comment on or make changes to this bug.