mail.imap.fetch_by_chunks is subordinant to mail.server.defaults.fetch_by_chunks

RESOLVED FIXED in Thunderbird 3.0b3

Status

MailNews Core
Networking: IMAP
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Alexander Kohr, Assigned: Usul)

Tracking

1.9.1 Branch
Thunderbird 3.0b3
PowerPC
Mac OS X
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1a2pre) Gecko/2008073100 Shredder/3.0b1pre

For some reason the more specific settings of mail.imap.fetch_by_chunks set to false will not override a more generic mail.server.defaults.fetch_by_chunks set to true.

Reproducible: Always

Steps to Reproduce:
1.Set up thunderbird to check email from an exchange server using the imap protocol.
2.Send that acount a message with a whole bunch of picture attachments say jpegs.
3.check the mail.( see it will only load part of one or more of the images due to bug number 9211 ( https://bugzilla.mozilla.org/show_bug.cgi?id=92111 )
4. Go into config editor (Shredder -> Preferences -> Advanced ->config editor & say you'll be careful)
5. filter for fetch_by_chunks and change mail.imap.fetch_by_chunks to be false. 
Actual Results:  
Only the first/some/if even one on larger ones image/s come in correctly from the exchange servers message then they partially come in.

Expected Results:  
That all of the images would load in there entirety.

I would think that the more specific mail.imap.fetch_by_chunks setting would overide the less specific for all mail servers mail.server.defaults.fetch_by_chunks setting.
This also occurs in thunderbird 2.0.0.14 as well. 

If you change the less specific mail.server.defaults.fetch_by_chunks setting than the full images load. 
As per the 9211 bur notes this seems to happen on macs more than windows. 

Also the way preference hierarchy seems to be set up is that the more specific takes precedence as if I manually add the following line to the 
user_pref(mail.server.serverXX.fetch_by_chunks, false);
where XX is a number greater than 1 that corresponds to the exchange servers imap account it overrides any general settings.

Comment 1

10 years ago
mail.imap.fetch_by_chunks is an older preference that is no longer used.  It has been replaced by the server-specific version.
(Assignee)

Comment 2

9 years ago
David is comment #1 true ?
Component: Preferences → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: preferences → networking.imap
Version: unspecified → 1.9.1 Branch
(Assignee)

Comment 3

9 years ago
Created attachment 382707 [details] [diff] [review]
remove the unused pref

After looking around with standard8 and mxr it seems that mail.imap.fetch_by_chunks is not used anymore - adding a patch to remove it.
Assignee: nobody → ludovic
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #382707 - Flags: superreview?(bienvenu)
Attachment #382707 - Flags: review?(bienvenu)

Updated

9 years ago
Attachment #382707 - Flags: superreview?(bienvenu)
Attachment #382707 - Flags: superreview+
Attachment #382707 - Flags: review?(bienvenu)
Attachment #382707 - Flags: review+

Comment 4

9 years ago
Comment on attachment 382707 [details] [diff] [review]
remove the unused pref

thx, yes, this moved to being per server with a server default.
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 3.0b3
Checked in: http://hg.mozilla.org/comm-central/rev/9c990709ec02

Marking as fixed as removing mail.imap.fetch_by_chunks removes the confusion.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.