If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Conditional jump or move depends on uninitialised value(s): nsDocumentEncoder::SerializeToStringRecursive

RESOLVED FIXED

Status

Core Graveyard
File Handling
RESOLVED FIXED
9 years ago
a year ago

People

(Reporter: mats, Assigned: Ben Karel [eschew])

Tracking

({regression, valgrind})

Trunk
x86
Linux
regression, valgrind

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 332859 [details]
Valgrind output

Conditional jump or move depends on uninitialised value(s): nsDocumentEncoder::SerializeToStringRecursive.

Looks like a regression from bug 293834.

STEPS TO REPRODUCE
0. Build Firefox with:
  ac_add_options --enable-jemalloc
  ac_add_options --with-valgrind
1. "firefox -g -d valgrind"
2. File->Quit

ACTUAL RESULTS
On exit:
==10580== Conditional jump or move depends on uninitialised value(s)
==10580==    at 0x18057D94: nsDocumentEncoder::SerializeToStringRecursive(nsIDOMNode*, nsAString_internal&, int) (nsDocumentEncoder.cpp:372)

http://hg.mozilla.org/mozilla-central/index.cgi/annotate/ce485b9145bf9cf354202ca0b8d1ad839f3338cc/content/base/src/nsDocumentEncoder.cpp#l372
(Assignee)

Comment 1

9 years ago
Created attachment 332861 [details] [diff] [review]
Initialize the variable

Strike two for me. Dead simple fix, though.
Assignee: nobody → eschew
Status: NEW → ASSIGNED
Attachment #332861 - Flags: review?(mats.palmgren)
Attachment #332861 - Flags: superreview+
Attachment #332861 - Flags: review?(mats.palmgren)
Attachment #332861 - Flags: review+
Pushed changeset 9ae2bcce0f4a.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.