Disable snav on xul content.

RESOLVED DUPLICATE of bug 444801

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 444801
10 years ago
10 years ago

People

(Reporter: Antonio Gomes (tonikitoo), Assigned: Antonio Gomes (tonikitoo))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
currently, spatial navigation works on page content only, but not xul content: e.g. if you go to 'about:config' , snav will just fails oddly.

just disable it in such cases ?
(Assignee)

Comment 1

10 years ago
Created attachment 339915 [details] [diff] [review]
v0.1 - disabile snav if on xuldocument
Assignee: nobody → tonikitoo
Status: NEW → ASSIGNED
Attachment #339915 - Flags: review?(doug.turner)

Comment 2

10 years ago
Comment on attachment 339915 [details] [diff] [review]
v0.1 - disabile snav if on xuldocument

are there other documents the we should also avoid?  svg?
(Assignee)

Comment 3

10 years ago
(In reply to comment #2)
> (From update of attachment 339915 [details] [diff] [review])
> are there other documents the we should also avoid?  svg?

yes, and probably in chrome content (google search bar, find bar) as well ... i will take a look
(Assignee)

Comment 4

10 years ago
(In reply to comment #2)
> (From update of attachment 339915 [details] [diff] [review])
> are there other documents the we should also avoid?  svg?

actually disabling snav for xul docs would break our mochitests.

hum, maybe snav mochitests could be .html not .xul ...

doug?

Comment 5

10 years ago
you could set a pref in mochitests

Comment 6

10 years ago
but ideally, maybe we just want snav to work in xul content.
(Assignee)

Comment 7

10 years ago
it is probably going to be fixed by bug 444801 at some point, marking as dup of it, then.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 444801

Updated

10 years ago
Attachment #339915 - Flags: review?(doug.turner) → review-

Comment 8

10 years ago
Comment on attachment 339915 [details] [diff] [review]
v0.1 - disabile snav if on xuldocument

this will break mochitests.  Also this is fixed "better" in bug 444801.
You need to log in before you can comment on or make changes to this bug.