when copying a jpg from a website and pasting it into powerpoint, there are extra pixels in the top right of the image

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: glenn.marcinuk, Unassigned)

Tracking

({regression})

1.9.0 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

when copying a jpg image from a website into a powerpoint (2003 sp3) presentation, there are extra pixels in the top right of the image.
Tried it copying images from Internet Explorer and there was no problem. Also tried it on a MAC (Leopard 10.5.4) using Firefox (3.0.1) with Powerpoint (2008)and there was no problem there either. 

Reproducible: Always

Steps to Reproduce:
1.Open a website and copy an image
2.paste it into a powerpoint presentation
3.in the top right of the image (typically in the white space framing the image)you will see a few extra pixels.
Actual Results:  
pixels appear every time when pasting a jpg image from a website into powerpoint

Expected Results:  
the jpg should have been pasted in cleanly without the extra pixels

Again tried it with Internet Explorer and then on a MAC with Firefox and it was fine in both cases.
(Reporter)

Comment 1

10 years ago
Created attachment 333402 [details]
there are extra pixels at the top right of the image
Created attachment 333404 [details]
screenshot of defect

this is WFM testing:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080811053724
+
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 ID:2008070208
+
Powerpoint 2003 SR3

can you provide a link to an example jpg?
added a screenshot of the defect from the attached ppt-file.
Duplicate of this bug: 453009
ok, confirmed now with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080830031750 Minefield/3.1b1pre ID:20080830031750 + Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 ID:2008070208

+ Microsoft Powerpoint 2003 SR3

works with Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16 ID:2008070205 => regression
Status: UNCONFIRMED → NEW
Component: General → Widget: Win32
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → win32
Version: unspecified → 1.9.0 Branch
Created attachment 336235 [details]
APNG example comparison of original + defective

be sure to watch the comparision with a proper viewer (e.g. Fx3)
example url: http://www.die-topnews.de/wp-content/uploads/firefox-3.jpg

Comment 6

10 years ago
Created attachment 341346 [details]
A sliver of the left side ends up on the right side

I have a similar but slightly different problem: When I Copy an image in Firefox 3 and Paste it into Powerpoint (2003 on Windows XP), a sliver of the image's left side ends up on its right side. (see attachment)

Original image here:
http://upload.wikimedia.org/wikipedia/commons/thumb/b/b1/Colouring_pencils.jpg/375px-Colouring_pencils.jpg

Copy-pasting from Firefox to Word works fine.
Copy-pasting from Firefox to Irfanview works fine.
Copy-pasting from Irfanview to Powerpoint works fine.
(In reply to comment #6)
> Created an attachment (id=341346) [details]
> A sliver of the left side ends up on the right side

This sounds very similar to the unconfirmed Bug 425069 to me. If this also occurs on 32 bit builds then the title of Bug 425069 needs to be changed.

Comment 8

7 years ago
This is working for me in Power Point 7 & Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110522 Firefox/6.0a1.

Resolving, please reopen if you still see the issue.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.