Filters should be disabled when removing an associated folder

RESOLVED DUPLICATE of bug 454589

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 454589
9 years ago
6 years ago

People

(Reporter: eddie, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 2.0.0.16

Filters should be disabled when removing an associated folder (when deleting the folders it says the associated filters will be disabled but I see that in the filters the checkbox i still checked so it is not disabled).... I would like to see the checkbox emptied to see which of the filters were associated with that folder, when deleting a folder to delete these associate folders after that....

(When a filter will be no longer used, it should be deleted as hundreds of filters will slow down the file downloading.)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

9 years ago
Confirmed same observation with Thunderbird 2.0.0.18 (Windows/20081105) on Windows Vista Home Premium SP1.

Tested on an IMAP mail server.

Steps to Reproduce:
1. Created message folder.
2. Created message filter using message folder as target.
3. Deleted message folder.
4. Thunderbird prompted me about disabling filter(s) related to the message folder.
5. Checked filter editor
6. Filter(s) still showing Enabled.
Flow was as follows: (tested with Tb trunk 2008/12/14 build)
(1) A filter rule points to a folder (say Folder-1).
(2) Delete Folder-1 => Folder-1 is moved to Trash/Folder-1
(3) Dialog says "filter will be disabled due to folder delete". 
    But Tb's real action on filter is same as one for "folder move".
    => Dialog of "filters associated with this folder will be updated"
       Pointer to Folder-1 in filter is changed to Trash/Folder-1.
       Filter rule is not disabled. 
(4) Rename Trash/Folder-1 to Trash/Folder-2
    => Dialog of "filters associated with this folder will be updated"
(5) Delete Trash/Folder-2 => Files for Trash/Folder-2 are deleted.
    No dialog or warning, no action on filter, 
    because "Delete under Trash" is not usual "Delete folder".
(6) If filter is edited, selected folder field in filter is cleared,
    then error of "You must select a target folder" occurs.
    If filter runs, and if a filter rule(which points to Trash/Folder-2) hits,
    move/copy failure occurs, then the filter rule is disabled.

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters

Comment 3

6 years ago
aceman, see comment 2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454589
You need to log in before you can comment on or make changes to this bug.