Bookmark search does not use bookmark keywords

RESOLVED DUPLICATE of bug 392143

Status

()

RESOLVED DUPLICATE of bug 392143
10 years ago
10 years ago

People

(Reporter: hr332003, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Firefox 3.0.1 for Windows as downloaded from the main website (http://www.mozilla.com/products/download.html?product=firefox-3.0.1&os=win&lang=en-US)

First off, thanks for the awesomeness that is Firefox!

In Firefox 3.0.1, if I search through my bookmarks (either in the Organize Bookmarks dialog or through the Awesome Bar) the search does not take into account bookmark keywords.

I can search by tags, but not by keywords. Hence, not all bookmark data fields are being indexed/searched, which leads to an incomplete search.

(I see this as a bug because for full awesomeness the Awesome Bar should search all fields in your bookmarks, no?)

Reproducible: Always

Steps to Reproduce:
1. Identify one of your bookmarks (let's say it's a bookmark to the BBC website) with the keyword News but not with tags
2. Type in the keyword News in your Awesome Bar
3.
Actual Results:  
The BBC bookmark does not show up in the quick-select options

Expected Results:  
The BBC bookmark does show up in the quick-select options

Thanks!!

Comment 1

10 years ago
This will be in version 3.1.  Until that's done you could use this:
https://addons.mozilla.org/en-US/firefox/addon/7755/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392143
(Reporter)

Comment 2

10 years ago
Thanks for the help, Brian.
You need to log in before you can comment on or make changes to this bug.