Last Comment Bug 450405 - scrollIntoView does not work in version 3.0.1
: scrollIntoView does not work in version 3.0.1
Status: RESOLVED INCOMPLETE
[CLOSEME 2010-11-01]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.flatratecarpet.com/Manhatt...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 06:31 PDT by John Alis
Modified: 2010-11-01 22:37 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description John Alis 2008-08-13 06:31:24 PDT
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648)
Build Identifier: 3.0.1

I have to use scrollIntoView instead of the standard use of anchor links, and it worked just fine on previous versions, and now turns out it doesn't work anymore. I also tried ScrollTo, but no luck.

Reproducible: Always

Steps to Reproduce:
1.Implement an onClick event
2.Run javascript:document.all('AnchorName').scrollIntoView();
Actual Results:  
Nothing happens

Expected Results:  
Scrolling the selected element into view
Comment 1 David Bolter [:davidb] 2008-10-21 07:43:18 PDT
I'd vote to bump the importance of this bug. scrollIntoView is needed by Web2.0 apps (and also for implementing the WAI-ARIA activedescendant pattern of managed focus).

Here is another test: http://www.quirksmode.org/dom/tests/scrollintoview.html
Comment 2 Tyler Downer [:Tyler] 2010-10-06 14:15:29 PDT
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Comment 3 Tyler Downer [:Tyler] 2010-11-01 22:37:39 PDT
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.

Note You need to log in before you can comment on or make changes to this bug.