Crash when playing ogg video [@ @0x110430 - ... - snd_pcm_set_params]

RESOLVED FIXED

Status

()

Core
Audio/Video
--
critical
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: James Graham, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1a2pre) Gecko/20080813020710 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1a2pre) Gecko/20080813020710 Minefield/3.1a2pre

Crash when trying to play the ogg video in the page in the URL field.

Reproducible: Always

Steps to Reproduce:
1. Click the load button
2. Click the play button



Crash reports http://crash-stats.mozilla.com/report/index/d3fc3714-6941-11dd-a250-001cc4e2bf68?p=1 and http://crash-stats.mozilla.com/report/index/9e5cde4c-6941-11dd-8ad9-001cc45a2ce4

Apparently under Windows and some other Linux setup this doesn't crash but does play too fast.

Comment 1

10 years ago
Confirming based on your crash reports.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Crash when playing ogg video → Crash when playing ogg video [@ @0x110430]
Version: unspecified → Trunk

Comment 2

10 years ago
What distribution of Linux is being used? Are you using PulseAudio? (Example works for me under Ubuntu 7.10).
(Reporter)

Comment 3

10 years ago
It's Fedora Core 8. We seem to have a bunch of pulseaudio packages installed:

pulseaudio-esound-compat-0.9.8-5.fc8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
kde-settings-pulseaudio-3.5-38.fc8
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-module-gconf-0.9.8-5.fc8
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-utils-0.9.8-5.fc8
pulseaudio-module-x11-0.9.8-5.fc8
pulseaudio-utils-0.9.8-5.fc8
pulseaudio-0.9.8-5.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
pulseaudio-core-libs-0.9.8-5.fc8
pulseaudio-libs-glib2-0.9.8-5.fc8

(listed in case the exact version makes any difference), but I'm not sure how to tell what the actual configuration being used is.

Updated

9 years ago
Depends on: 461135

Comment 4

9 years ago
Bug 461135 was landed which should fix this issue. Can you confirm? The test video plays fine on PulseAudio based distro's for me.

Comment 5

9 years ago
you could try grabbing a build of firefox from fc8 and following these instructions (which should be added to https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report#Linux ) from
http://www.chruz.com/2008/01/22/when-firefox-crashes-and-burns/

# yum install yum-utils
# debuginfo-install firefox
# ./firefox -g -d gdb

(not certain about that last line, it depends on whether the red hat firefox script supports -g, if not, gdb ./firefox-bin )

or perhaps we should just add http://fedoraproject.org/wiki/StackTraces
Keywords: crash, stackwanted
Summary: Crash when playing ogg video [@ @0x110430] → Crash when playing ogg video [@ @0x110430 - ... - snd_pcm_set_params]

Comment 6

9 years ago
(In reply to comment #2)
> What distribution of Linux is being used? Are you using PulseAudio? (Example
> works for me under Ubuntu 7.10).

i use ubuntu 8.10 with pulseaudio and i hear just noise.
when i close ff after playing a video i receive:

E: mutex-posix.c: Assertion 'pthread_mutex_lock(&m->mutex) == 0' failed at pulsecore/mutex-posix.c:92, function pa_mutex_lock(). Aborting.

Comment 7

9 years ago
please file a different bug for that.
Works for me, Firefox 3.2a1pre (20090304) on Linux.

Comment 9

9 years ago
Content plays for me on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090318 Shiretoko/3.5b4pre

I checked the crash stacks for the last week for stacks that contained 0x110430, 0 was returned.
Marking resolved fixed as per comments 4, 8, and 9.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Crash Signature: [@ @0x110430 - ... - snd_pcm_set_params]
You need to log in before you can comment on or make changes to this bug.