Closed Bug 450455 Opened 11 years ago Closed 7 years ago

Youtube Crash

Categories

(Core :: DOM: Core & HTML, defect, critical)

1.9.2 Branch
x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 760190

People

(Reporter: skar80, Unassigned)

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-AR; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-AR; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1

Firefox crashes &  self shutdown when opening certain youtube.com videos. 

Reproducible: Sometimes

Steps to Reproduce:
1.Enter youtube.com
2. Select a random video  
3. browse among the related videos

Actual Results:  
firefox sometimes will shutdown, without any message or warning.

Expected Results:  
Not shuting down, play every video correctly
Same thing is happening to me. If I go to YouTube, then select another video to play, FireFox crashes, the crash reporter thingy pops up, then I restart FireFox and attempt to get to the video I want again. Isn't just happening on one certain video.

Firefox doesn't give a Windows warning saying it needs to shut down, it just disappears and that crash thing opens up.
Component: Shell Integration → Plug-ins
Product: Firefox → Core
QA Contact: shell.integration → plugins
Same thing happens to me on Suse 11.1 64-bit but with my own 3.5.2 installation. It plays the video, but leaving youtube, or switching to another video crashes the browser. This happens every time.

3.0.12 works like a charm, though.
I believe I've just seen this crash:
http://crash-stats.mozilla.com/report/index/8f420e92-692e-4a2c-9447-826862100210
Status: UNCONFIRMED → NEW
Ever confirmed: true
Signature	operator new(unsigned int) | CSSParserImpl::ParseSelectorGroup(nsCSSSelectorList*&)
UUID	8f420e92-692e-4a2c-9447-826862100210
Time 	2010-02-10 08:02:12.634982
Uptime	1281
Last Crash	257937 seconds before submission
Product	Firefox
Version	3.7a2pre
Build ID	20100209073221
Branch	1.9.3
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 6
Crash Reason	Unhandled C++ Exception
Crash Address	0x7c812afb
User Comments	
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	kernel32.dll 	RaiseException 	
1 	mozcrt19.dll 	_CxxThrowException 	throw.cpp:159
2 	mozcrt19.dll 	operator new 	obj-firefox/memory/jemalloc/crtsrc/new.cpp:57
3 	xul.dll 	CSSParserImpl::ParseSelectorGroup 	layout/style/nsCSSParser.cpp:2554
4 	xul.dll 	CSSParserImpl::ParseSelectorList 	layout/style/nsCSSParser.cpp:2457
5 	xul.dll 	CSSParserImpl::ParseRuleSet 	layout/style/nsCSSParser.cpp:2413
6 	xul.dll 	CSSParserImpl::GetToken 	layout/style/nsCSSParser.cpp:1303
7 		@0x0 	
8 	xul.dll 	CSSParserImpl::Parse 	layout/style/nsCSSParser.cpp:927
9 	xul.dll 	CreateElementTxn::cycleCollection::Traverse 	
10 	xul.dll 	CSSLoaderImpl::ParseSheet 	layout/style/nsCSSLoader.cpp:1558

this is an oom exception...
Keywords: crash
Yes, I agree, though I didn't see any of the lag or sluggishness one would usually expect on a machine with 4GB of memory as it filled up entirely.  The crash happened very quickly.  Perhaps heap corruption is the root cause?
Time for purify or something? Windbg and some other things have some support for heap tracking, but....
Signature	operator new(unsigned int) | nsGenericElement::QueryInterface(nsID const&, void**)
UUID	fe90aeec-626e-4c7b-a1e0-e49ab2100210
Time 	2010-02-10 13:45:50.401360
Uptime	9562
Last Crash	20618 seconds before submission
Product	Firefox
Version	3.7a2pre
Build ID	20100210071710
Branch	1.9.3
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 6
Crash Reason	Unhandled C++ Exception
Crash Address	0x7c812afb
User Comments	
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	kernel32.dll 	RaiseException 	
1 	mozcrt19.dll 	_CxxThrowException 	throw.cpp:159
2 	mozcrt19.dll 	operator new 	obj-firefox/memory/jemalloc/crtsrc/new.cpp:57
3 	xul.dll 	nsGenericElement::QueryInterface 	
4 	xul.dll 	nsHTMLDivElement::QueryInterface 	content/html/content/src/nsHTMLDivElement.cpp:99
5 	xul.dll 	xul.dll@0x9d556f 	
6 	xul.dll 	xpc_qsUnwrapThisImpl 	js/src/xpconnect/src/xpcquickstubs.cpp:850
7 	xul.dll 	nsIDOMNodeSelector_QuerySelectorAll 	obj-firefox/js/src/xpconnect/src/dom_quickstubs.cpp:5445
8 		@0x11390c3 	
9 	mozcrt19.dll 	malloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:5790
10 	mozjs.dll 	array_getProperty 	js/src/jsarray.cpp:796
11 		@0x12c70b 	
12 	mozjs.dll 	js_Interpret 	js/src/jsops.cpp:2270
Component: Plug-ins → DOM
QA Contact: plugins → general
signature is 3.6 only.
signature looks to have morphed to bug 760190
Status: NEW → RESOLVED
Crash Signature: [@ operator new(unsigned int) | CSSParserImpl::ParseSelectorGroup(nsCSSSelectorList*&)]
Closed: 7 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.9.2 Branch
Duplicate of bug: 760190
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.