All users were logged out of Bugzilla on October 13th, 2018

Camino brings iMac 2.4g to a crawl

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: jrhett, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

I'm sad to report my least detailed bug report ever.  I can't figure out what is happening.  top shows Camino at consistent 11% utilization, but the system has high idle time.  iostat shows low disk activity.  But closing Camino makes the entire system snappy again.

Fully story: use Camino on a Powerbook every day.  Works great.  Bought an iMac for home and of course installed Camino.  Well... the iMac just seemed overall slow.  Very slow.  Confusing, since it's twice the CPU and memory of my Powerbook.  I blamed it on Intel.

Then it got worse.  Quicktime movies played super slow, breaking up.  Nothing worked well at all.  Finally doing some diagnosis, I found that it was only happening when Camino was running.

So I installed Firefox3 and used that for 2 weeks.  No problems.  Everything is snappy.  Everything works.  

Then I remember why I like Camino -- password sync via MobileMe.  So I restart Camino, and within 3 hours my system is dragging.  Time from moving the mouse to screen wakeup -- 17 seconds.  Time from click in a window until it raises focus -- 3 seconds.  Movies are entirely unwatchable.

Problem is -- I can't figure out what's wrong.  While this is happening, the system shows 98% idle in "top", and iostat shows no significant traffic.  There's more than half a gig of memory free.

I love Camino.  How can I help debug this problem?

Reproducible: Always

Steps to Reproduce:
1.  Start Camino
2.  Browse some sites
3.  Wait for the system to slow down

Comment 1

10 years ago
What version of Camino are you running? Please either report bugs with Camino, or provide the build number.

Comment 2

10 years ago
Also, have you checked that Camino is not set to open in Rosetta?
(Reporter)

Comment 3

10 years ago
Version 1.6.3 (1.8.1.16 2008080311)

And I'm not using Rosetta.  

Comment 4

10 years ago
Does it happen with a clean profile? (You can test with <http://pimpmycamino.com/parts/troubleshoot-camino>)

Does it happen with a current trunk nightly build? If you haven't run a trunk nightly in the last year or so, you'll need to make a copy of your profile (~/Library/Application Support/Camino) before running it so you have something to go back to, since Gecko 1.9 will migrate your cookies and site permissions into a format that Camino 1.6 doesn't know how to read.

Comment 5

10 years ago
Might want to try upgrading Flash, too. This doesn't sound like the other Flash CPu bugs we've seen but it's worth a shot.
(Reporter)

Comment 6

10 years ago
I wasn't using any flash sites.  I avoid them.

I would have a problem running a trunk build.  Going back to 1.6 is irrelevant since it makes the system unusable.

Comment 7

10 years ago
(In reply to comment #6)
> I would have a problem running a trunk build.

Could you elaborate? If you can't test a current build, I doubt we can make any progress here, since you are the only one who can reproduce the problem.
(Reporter)

Comment 8

10 years ago
Sorry, I meant "no problem running a trunk build"

I'm out of town tomorrow, but will start testing on Saturday.
(Reporter)

Comment 9

10 years ago
Okay, I'm now using Version 2.0a1pre (1.9.0.2pre 2008081500) and the problem is not repeating.  Given that it was trivial to recreate before, running for 5 days with no problems (and only restarted Camino once and the system not at all) means that this is likely solved.

FYI, I spend an evening browsing Youtube just to confirm that Flash works fine too.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

10 years ago
This is not resolved.  It took a while for me to recreate, but it's simple enough.  The problem only occurs after waking the iMac from sleep.  As long as I close Camino before walking away and open it up when I come back, the problem does not occur.

Difference: if I leave Camino and the iMac sleeps for more than 12 hours, it will take more than 20 seconds for the screen to update and me to gain mouse control when I touch the keyboard again.  Without Camino, it's instant.

Once woken in this fashion, the entire system is slow and unresponsive until I force kill Camino.   Simply selecting Camino to the foreground takes 3-5 minutes, and CMD-Q takes roughly 22 minutes to complete.  Everything else on the system is likewise slow.

ONLY after a long sleep period, and NEVER if I always close Camino before walking away.

Firefox has no similar problems.  My system has now had Firefox 3.02 running since the first release date, no problem.
(Reporter)

Comment 11

10 years ago
Again, testing with the 10/19 build produced this same effect overnight.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 12

10 years ago
(In reply to comment #10)
> Once woken in this fashion, the entire system is slow and unresponsive until I
> force kill Camino.   Simply selecting Camino to the foreground takes 3-5
> minutes, and CMD-Q takes roughly 22 minutes to complete.  Everything else on
> the system is likewise slow.

And during all this, Camino is still not using significant amounts of CPU?

Could you get a sample of Camino in this state using activity monitor, and attach it here with the "Add an attachment" link above?
(Reporter)

Comment 13

10 years ago
Not using significant amounts of CPU according to "top".  CPU will be 98% idle, but nothing happens quickly.

I'll get the sample using Activity Monitor.
(Reporter)

Comment 14

10 years ago
Created attachment 350185 [details]
Application Monitor sample of Camino bringing system to crawl after sleep

This actually happened on my PowerBook this morning.  I woke it from a 2-day sleep and the system is at a crawl.   To get the application sample and then upload it to you has taken an hour.
(Reporter)

Comment 15

10 years ago
FWIW this was Version 2.0a1 (1.9.0.4pre 2008101818) on a PowerBook 1.5g with 1gb ram

Updated

10 years ago
Attachment #350185 - Attachment mime type: application/octet-stream → text/plain

Comment 16

10 years ago
Comment on attachment 350185 [details]
Application Monitor sample of Camino bringing system to crawl after sleep

This sample is showing almost the entire time spent in Flash.
(Reporter)

Comment 18

10 years ago
I never found a way to figure that out, but I've upgraded it to the latest.

Comment 19

10 years ago
(In reply to comment #18)
> I never found a way to figure that out, but I've upgraded it to the latest.

For future reference, Control-clicking on any Flash animation in a Web page will give you the major version in the context menu, or you can visit about:plugins (or Help -> Installed Plug-Ins), and that'll give you the full version.

cl
Or "Get Info" on /Library/Internet Plug-Ins/Flash Player.plugin in the Finder ;)
Jo, is this still happening with the newer version of Flash?
(Reporter)

Comment 22

10 years ago
Yes.  I have a new MacBook and it's happening on that system too.  3 different platforms and it happens any time I leave windows open and let the computer go to sleep.

I've pretty much given up on this.  I close Camino every time I walk away from the computer now.  In fact, if I can ever find a way to get Firefox to use the keychain, I'm ready to dump Camino.  The only feature I care about is the keychain integration, which is essential for me.

Instead of wasting time to fix Camino, why not just port your keychain integration over to Firefox?

Comment 23

10 years ago
Since none of us can reproduce this on any of our machines (and we don't have any leads from the described behavior), the only reporter thinks Camino is a waste of time, and we have better things to do with our (volunteer) time than deal with abusive reports, closing.

If anyone else sees this, and wants to help us debug further instead of insulting us, please file a new bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 24

10 years ago
I have helped you debug.  I have supplied everything you have asked for, including the Application Monitor Sample.  And I can replicate this at will on a Powerbook 1.5g, an iMac 2.0g and a brand new MacBook 2.4g.  Any time, any time.

I'm not insulting you, I am frustrated that there is apparently zero interest in solving this major problem.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 25

10 years ago
One more time: what version of Flash are you using?
(Reporter)

Comment 26

10 years ago
On my PowerMac it's

 File name: Flash Player.plugin
    Shockwave Flash 10.0 r12

I'll check on the other two as soon as I see them.

FWIW, this slowdown happened to me yesterday.  Same as always, a page using flash in the background (behind other windows) after Sleep.

Comment 27

10 years ago
(In reply to comment #24)
> I'm not insulting you
(In reply to comment #22)
> Instead of wasting time to fix Camino

As it turns out, calling the product that all of us pour our free time into building a waste of time is, in fact, insulting.

> I am frustrated that there is apparently zero interest in solving
> this major problem.

You told us that you had given up on this bug and had no interesting in seeing Camino fixed, but are frustrated that the result wasn't that we then dropped everything to try to work with you more to debug this? I'm not sure why you expected it to work that way, but for future reference: if our only lead on a bug tells us that they don't care and aren't going to help us any more, we assume that means they aren't going to help us any more, and we stop working on the bug until we have a new lead we can make progress with.
(Reporter)

Comment 28

10 years ago
> You told us that you had given up on this bug and had no interesting in seeing
> Camino fixed, but are frustrated that the result wasn't that we then dropped
> everything to try to work with you more to debug this? 

I hadn't given up on the bug.  If you look at the history I responded promptly to every query on this bug.  What had happened was... well nothing at all.  Silence on your end.  And then "is it still happening" after more than a month of silence.  So please stop blaming the reporter, and perhaps work the bug?

Comment 29

10 years ago
The delay after you said you had updated Flash was because we were waiting to find out if the new version of Flash resolved the problem, given that the problem you were having seemed to be related to Flash (which still seems to be the case given your recent comments). I'm sorry we didn't mention that right away, but we did follow up on it. I'

(In reply to comment #28)
> I hadn't given up on the bug.

I must have misread the sentence "I've pretty much given up on this." then.

Comment 30

10 years ago
(And just to be clear, my comments aren't about blame, but correcting your false assertion that we had "zero interest in solving this major problem".)
(Reporter)

Comment 31

10 years ago
> And just to be clear, my comments aren't about blame, but correcting your
> false assertion that we had "zero interest in solving this major problem".

That's good to hear.  Tell me what you need, this is a major issue and I'm happy to provide anything I can.

Comment 32

10 years ago
> Tell me what you need

Personally, I would need (as I indicated in comment 23) a report from someone who hasn't been displaying an attitude in recent bugs that leads me to believe that trying to cooperate on debugging would be an aggravating and ultimately unproductive use of my free time, preferably filed in a new bug that isn't confused by having originally been about what sounds like a very different issue (hangs within a few hours with no flash, using 1.6.x, vs. only when leaving flash pages open for 12+ hour sleep cycles in 2.0 builds).

Having clarified why I closed the bug in the first place (and why it didn't progress after comment 22), I'm done here. If you prefer to leave this bug open in the hopes that another Camino developer will have a different conclusion about the usefulness of continuing here, so be it.
(Reporter)

Comment 33

10 years ago
You have a clear description.  You have a repeatable, reproducible bug in evidence on every platform.  But you can't be bothered to investigate.

The only attitude problem here in yours, Stuart.

My only problem is that this very serious issue continues to be ignored 8 months after I originally reported it.

Does Camino have any developers who aren't so busy insulting bug reporters that they might actually attempt to solve the problem?

Comment 34

10 years ago
I'll try to clarify this one more time:

> You have a clear description.

We have a description, but according to that description we aren't using excessive CPU, memory, or disk I/O, so all we have is a general symptom with no apparent cause. That's clearly not enough to solve the problem all by itself, bringing us to:

> You have a repeatable, reproducible bug in evidence on every platform.

No, *you* have a repeatable, reproducible bug. As I indicated in comment 23, none of us can reproduce it. Nobody else has ever reported seeing it either. So we can't investigate it directly, only indirectly through you.

> My only problem is that this very serious issue continues to be ignored 8
> months after I originally reported it.

Of those 8 months:
- For three of them, it was closed by you.
- For half of one we were waiting for you to answer the question "What version of Flash do you have?" (since we had significant evidence that Flash is involved).
- For one we forgot to ask if you were still experiencing it after updating Flash; our mistake.
- For three of them, we didn't take any action because all of us read your comment 22 as clearly indicating that you didn't want to try to debug this any more, and as indicated above, we had no other way to get any more information.

Mischaracterizing the history of this bug as some sort of grossly negligent behavior on our part is not going to win people over to the idea that you genuinely want to work with anyone on this.
(Reporter)

Comment 35

10 years ago
There are multiple valid points of view on this.  I acknowledge that some of what you've said is valid.   But can we stop arguing like girlfriends and start focusing on a solution?

Given that I can recreate this on both platforms with ease, I'm confused that you cannot.  What part of the recreation step produces difficulty?

1. Open a new window
2. Browse to a flash-using site.
3. Make a different window active, and leave the flash using site in the background
4. Go away from your computer long enough for it to go to sleep (per Power settings on that mac obviously)
5. Wake it up, observe sluggish behavior in the system overall

Comment 36

10 years ago
(In reply to comment #35)

> 1. Open a new window
> 2. Browse to a flash-using site.
> 3. Make a different window active, and leave the flash using site in the
> background

If you have Flashblock on, does anything change?

> 4. Go away from your computer long enough for it to go to sleep (per Power
> settings on that mac obviously)

Do you have to let the system sleep itself, or is manually putting it to sleep sufficient?
(Reporter)

Comment 37

10 years ago
What is flashblock? (probably answers your question)

I don't know. I'll try and recreate it with a forced sleep and see.

FWIW, I don't see this problem on my Macbook when I close its lid (which puts
it to sleep) and open it again later.  But if I leave the screen open and it
goes to sleep on its own (like overnight) it's fairly common.

Comment 38

10 years ago
Have you been able to recreate this with a commanded (rather than automatic) sleep?

How about if you disable/uninstall Flash for a week or two, or even just enable Flashblock (the "Block Flash animations" checkbox in Web Features)?
(Reporter)

Comment 39

10 years ago
I'm sorry, but after the full on Stuart Morgan experience, I lost interest in being abused for reporting bugs.

Since the bug reported here happened pretty much daily on all 3 platforms, had been going on for nearly a year now, I had to look around.  Safari is pretty good these days, so I'm using it full time now.  And it doesn't have this problem.

My comments from the final weeks of using Camino (late April):

1. Forced sleep by immediate re-awaken doesn't demonstrate the problem.

2. Walking away after forced sleep and coming back later does show the problem, however it's much the same as walking away and letting it sleep.   I couldn't find exactly how much time was required, but it seemed to be at least 1 hour.  For example, it never happened mid-day when I would go out for lunch or anything, but did happen once when I was gone for 4 hours from the office.

And finally, the key is to have an open window in the background which uses flash animation.  I don't use tabs --ever-- so I don't know if you can recreate it with tabs.  I'm guilty of having as many as 126 open browser windows at a time, layered on each other.   But I have seen the problem manifest with as little as 6 Camino windows, although it's more common that I have 20+...

The site which was likely the most common in the background using flash animation for me was http://www.roadracingworld.com/

Comment 40

10 years ago
INVALID, since this is very likely a Flash bug, then. If someone can find STR other than the reporter, file a new bug and cc msintov.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 41

10 years ago
You're skipping one problem here.  It doesn't happen in either Firefox or Safari.   When I gave up on Camino the first time and went to Firefox it never happened in 8 weeks.  I've been on Safari full time for 6+ weeks and it has never happened.

So yes it's related to Flash, but it's specific to Camino.

Comment 42

10 years ago
At the risk of repeating myself:

If someone other than the reporter can find a way to reproduce this, file a NEW BUG and cc msintov.
You need to log in before you can comment on or make changes to this bug.