Closed Bug 450735 Opened 12 years ago Closed 12 years ago

Firefox doesn't respond to mouse clicks on links and buttons

Categories

(Firefox :: General, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: martin2, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Error description:
Whenever I start my Firefox browser, I can only click once on a button or link or enter an address or open a new tab. After this first command I cannot click anything with a "function" anymore (such as submit buttons, back button, close buttons, links, tabs, the Firefox menue, bookmarks).

There is no error message. The problem appears only with Firefox.

Work-around:
It sometimes helps to right-click on the top bar of the window, then left click inside the window. This doesn't always work. If it does, I have one click again, before the problem reappears.

Most of the time it helps to click on my windows "Show Desktop" Button. When I maximize Firefox after that, I have one click again before the problem reappears.

It always helps to alt+tab out of Firefox. Problem reappears in the same way described above.

In any case there is no real work-around. The problem appeared after I had been using Firefox 3.0.1 for many weeks and it doesn't go away. I tried reboots, reinstalling Firefox, memcheck, virus and spyware checks, disabled all add-ons. No change. I have not yet tried an older version of Firefox. I am using IE now :-(

Variations:
Sometimes (<10%) it even affects all of the windows explorer. I cannot click on anything then before I use alt+tab!

Sometimes (20-50%)it doesn't affect the menu items and the back button but all other links and buttons

Sometimes I have more than one click (two to four clicks) before the problem appears. This is in 10-20% of the cases.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox (Default Web Page/In my case: google)
2. Click on a Form Button or Link inside the browser window.

Actual Results:  
=> The next such attempt to click anything with a "function" fails. Links are not highlighted on mouseover nor does the mousepointer change.


Expected Results:  
Command connected to the button / link / Firefox-button or menue item should be executed.

see "Details".
Do you get the same issue in the Firefox safemode ?
- http://kb.mozillazine.org/Safe+mode
Yes, same issue in the safe mode.

There is a thread in the Mozilla support forum where people post similar problems.
See http://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&forumId=1&comments_parentId=86324#threadId109010
I have solved the problem for myself. It was not a bug, but a mechanical problem. Nevertheless Firefox is the only browser that seemed to be affected:

My middle mouse button was not working. I realized that, when I opened Excel and found the program selecting multiple cells as if I kept pressing the left mouse button.

I opened my mouse and found that the little mechanical transmitter for the middle mouse button (wheel)was jammed. I released it and now everything works fine.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
I also have this problem or one very like it. No problem with Firefox 2.0.16, started right after upgrade to 3.0. I get one chance to follow a hot link, after that, Firefox appears completely frozen. Links do nothing, toolbar buttons do nothing, the main close box in the title bar does nothing. Menus still work, at least the few times I've tried. I have a perfectly ordinary Microsoft 2-button mouse, and also a trackpad (using a Dell Latitude D820, XP SP3). Switching to another application and back seems to fix the problem (for one link). When a link opens a second window, the original window may still give me one more click.
I've used Firefox since the very beginning and the mouse bug has only appeared in version 3.0.3 for me.  Tried 3 different mice from different companies, using the manufacturer'ds driver and Microsoft's generic one, same problem. Looks like something needs to be done.  

I'm going back to IE in the meantime as it is VERY annoying.
The problem eventually went away for me...I think after I restarted the computer.
You need to log in before you can comment on or make changes to this bug.