Last Comment Bug 450864 - c++ style comment in parser/expat/lib/moz_extensions.c
: c++ style comment in parser/expat/lib/moz_extensions.c
Status: VERIFIED FIXED
[branch only]
: verified1.8.1.18
Product: Core
Classification: Components
Component: XML (show other bugs)
: 1.8 Branch
: Other All
: -- normal (vote)
: ---
Assigned To: Uli Link (:ul-mcamafia)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-16 03:00 PDT by Uli Link (:ul-mcamafia)
Modified: 2008-10-21 14:36 PDT (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
replaces c++ with c style comment only (937 bytes, patch)
2008-08-16 03:05 PDT, Uli Link (:ul-mcamafia)
peterv: review+
peterv: superreview+
dveditz: approval1.8.1.18+
Details | Diff | Splinter Review

Description Uli Link (:ul-mcamafia) 2008-08-16 03:00:07 PDT
User-Agent:       Mozilla/5.0 (X11; U; AIX 5.1; en-US; rv:1.8.1.16) Gecko/20080806 Firefox/2.0.0.16
Build Identifier: MOZILLA_1_8_BRANCH

build bustage due to illegal C code
MOZILLA_1_8_BRANCH is not required a C99 C compiler, so c++ style comments are illegal in .c files

Reproducible: Always

Steps to Reproduce:
1. compile on AIX 4.3.3 or AIX 5.1 with VisualAge 5.0.2.9

Actual Results:  
compilation error

Expected Results:  
successfull compilation
Comment 1 Uli Link (:ul-mcamafia) 2008-08-16 03:05:45 PDT
Created attachment 334075 [details] [diff] [review]
replaces c++ with c style comment only

Trunk and fx 3.0 requires a C99 compiler, so no problems with c++ style comments in c files.
Comment 2 Peter Van der Beken [:peterv] 2008-09-05 03:24:17 PDT
Comment on attachment 334075 [details] [diff] [review]
replaces c++ with c style comment only

This was already fixed on 1.9/trunk. No functional changes, just a fix to make it compile with more compilers.
Comment 3 Daniel Veditz [:dveditz] 2008-09-05 11:32:14 PDT
Not a blocker, will look at the approval requests
Comment 4 Serge Gautherie (:sgautherie) 2008-10-13 10:35:21 PDT
(In reply to comment #2)
> This was already fixed on 1.9/trunk

by
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/parser/expat/lib/moz_extensions.c&mark=1.10
Comment 5 Magnus Melin 2008-10-19 09:03:59 PDT
Checking in parser/expat/lib/moz_extensions.c;
/cvsroot/mozilla/parser/expat/lib/moz_extensions.c,v  <--  moz_extensions.c
new revision: 1.6.18.2; previous revision: 1.6.18.1
done

->FIXED

Note You need to log in before you can comment on or make changes to this bug.