Last Comment Bug 450865 - c++ style comment in js/src/jsemit.c
: c++ style comment in js/src/jsemit.c
Status: VERIFIED FIXED
: verified1.8.1.17
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 1.8 Branch
: All All
: -- minor (vote)
: ---
Assigned To: Brian Crowder
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-16 03:18 PDT by Uli Link (:ul-mcamafia)
Modified: 2008-09-18 13:33 PDT (History)
6 users (show)
bob: in‑testsuite-
bob: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
replaces c++ with c style comment only (1016 bytes, patch)
2008-08-16 03:21 PDT, Uli Link (:ul-mcamafia)
shaver: review+
dveditz: approval1.8.1.17+
Details | Diff | Review

Description Uli Link (:ul-mcamafia) 2008-08-16 03:18:21 PDT
User-Agent:       Mozilla/5.0 (X11; U; AIX 5.1; en-US; rv:1.8.1.16) Gecko/20080806 Firefox/2.0.0.16
Build Identifier: MOZILLA_1_8_BRANCH

build bustage due to c++ style comment in c source file

Reproducible: Always

Steps to Reproduce:
1. build with a C89 ANSI C compiler

Actual Results:  
comilation error due to illegal C code

Expected Results:  
successful compilation

Trunk requires C99 compiler, but MOZILLA_1_8_BRANCH still supports C89 ANSI compilers.
Found this with  VisualAge C++ 5.0.2.9 on AIX 4.3.3 (which has no C99!)
Comment 1 Uli Link (:ul-mcamafia) 2008-08-16 03:21:14 PDT
Created attachment 334078 [details] [diff] [review]
replaces c++ with c style comment only

This trivial patch makes jsemit.c compile on pre-C99 C compilers on branch MOZILLA_1_8_BRANCH
Comment 2 Mike Shaver (:shaver -- probably not reading bugmail closely) 2008-08-16 05:55:38 PDT
Comment on attachment 334078 [details] [diff] [review]
replaces c++ with c style comment only

r=shaver, sure.
Comment 3 Brian Crowder 2008-08-17 07:15:49 PDT
As trivial as it is, I don't think this can land w/o branch approval.  (correct me if I'm wrong, shaver)
Comment 4 Brian Crowder 2008-08-17 07:16:07 PDT
Comment on attachment 334078 [details] [diff] [review]
replaces c++ with c style comment only

Trivial.
Comment 5 Brian Crowder 2008-08-17 07:18:31 PDT
Comment on attachment 334078 [details] [diff] [review]
replaces c++ with c style comment only

Woops, wrong branch.
Comment 6 Daniel Veditz [:dveditz] 2008-08-20 15:00:55 PDT
-> crowder for check-in
Comment 7 Daniel Veditz [:dveditz] 2008-08-20 15:01:11 PDT
Comment on attachment 334078 [details] [diff] [review]
replaces c++ with c style comment only

Approved for 1.8.1.17, a=dveditz for release-drivers.
Comment 8 Samuel Sidler (old account; do not CC) 2008-08-20 15:22:50 PDT
Adding keyword...
Comment 9 Brian Crowder 2008-08-20 15:25:10 PDT
Sorry, didn't think the keyword was necessary; as this is 1.8.1.17-only.
Comment 10 Samuel Sidler (old account; do not CC) 2008-08-20 15:30:58 PDT
Sadly, we do, since the only way to track branch bugs is by keyword. Bugzilla sucks. :(
Comment 11 Stephen Donner [:stephend] - PTO; back on 5/28 2008-08-29 17:06:24 PDT
Verified FIXED using

http://mxr.mozilla.org/mozilla1.8/source/js/src/jsemit.c#608:

608             /* FALL THROUGH */

Replacing fixed1.8.1.17 with verified1.8.1.17, and marked as Verified FIXED.

Note You need to log in before you can comment on or make changes to this bug.