The default bug view has changed. See this FAQ.

missing support for AIX target in configure.in

RESOLVED FIXED in mozilla1.9.1b2

Status

()

Core
Build Config
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: ul, Assigned: ul)

Tracking

({fixed1.9.0.4, verified1.8.1.18})

unspecified
mozilla1.9.1b2
Other
AIX
fixed1.9.0.4, verified1.8.1.18
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; AIX 5.1; en-US; rv:1.8.1.16) Gecko/20080806 Firefox/2.0.0.16
Build Identifier: 

Issuing the following javascript command in the javascript console results in
error NS_ERROR_NOT_AVAILABLE:

Components.classes["@mozilla.org/xre/app-info;1"].getService(Components.interfaces.nsIXULRuntime).XPCOMABI


Reproducible: Always

Steps to Reproduce:
1. configure the source on AIX 4.3.3 or
2. use a machine with POWER or POWER2 cpu which configures ${target_cpu} to rs6000 instead of powerpc
3.
Actual Results:  
XPCOMABI is not set if any of both applies

Expected Results:  
XPCOMABI is set to ppc-ibmc

Follow-up fix of bug 323997
(Assignee)

Comment 1

9 years ago
Created attachment 334124 [details] [diff] [review]
fixes CPU_ARCH for RS/6000 w/o powerpc CPU also
(Assignee)

Updated

9 years ago
Attachment #334124 - Flags: review+
(Assignee)

Comment 2

9 years ago
review by cls under bug 323997
(Assignee)

Comment 3

9 years ago
Comment on attachment 334124 [details] [diff] [review]
fixes CPU_ARCH for RS/6000 w/o powerpc CPU also

approval for MOZILLA_1_8_BRANCH is wanted after at least two weeks on trunk
Attachment #334124 - Flags: review?(benjamin)
Assignee: nobody → ul.mcamafia
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

9 years ago
Created attachment 334150 [details] [diff] [review]
Clear out MOZ_FIX_LINK_PATHS

requesting review for jag's Patch of bug 332075
Attachment #334150 - Flags: review?
(Assignee)

Comment 5

9 years ago
Comment on attachment 334150 [details] [diff] [review]
Clear out MOZ_FIX_LINK_PATHS

the AIX linker has no equivalent to -Wl,-rpath-link

symbols are resolved at link-time by the linker in order of the given -L and -l flags on the commandline. With -blibpath: flag the -L directories are not linkedited into the binary and the lib searchpath is only the path given by -blibpath: + any directories in LIBPATH environment variable. LIBPATH is set  in run-mozilla.sh

Since the AIX port isn't supported with GCC, and even with GCC better use native ld on AIX.
So clearing MOZ_FIX_LINK_PATH for AIX is needed.
Attachment #334150 - Flags: review? → review?(benjamin)
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Attachment #334124 - Attachment is obsolete: true
Attachment #334124 - Flags: review?(benjamin)
(Assignee)

Updated

9 years ago
Attachment #334150 - Attachment is obsolete: true
Attachment #334150 - Flags: review?(benjamin)
(Assignee)

Comment 6

9 years ago
Created attachment 334172 [details] [diff] [review]
[checked in on 1.8] clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH

Merged both fixes into one for branch MOZILLA_1_8_BRANCH only
The resulting "configure" generates (objdir)config/autoconf.mk verified ok on AIX.
HEAD still contains the MOZ_FIX_LINK_PATH fix bug 323997 for more than 2 years.

The pythonized configure seems to need a slightly different patch, as it is broken on AIX by now.
Attachment #334172 - Flags: review?(cls)
(Assignee)

Comment 7

9 years ago
Created attachment 334174 [details] [diff] [review]
set XPCOMABI on AIX and raise minimum compiler version CVS HEAD

For 1.9 branch the VisualAge 5.0.2 not sufficiant any longer, as starting with VisualAge 6  the C compiler supports the C99 language level, which is heavily used in gfx.
The MOZ_FIX_LINK_PATH bug 323997 fix has still landed on 1.9
TARGET_CPU for XPCOMABI is set just like the patch for 1.8 branch
Attachment #334174 - Flags: review?(cls)
(Assignee)

Updated

9 years ago
Attachment #334124 - Flags: review+
(Assignee)

Updated

9 years ago
Blocks: 332075
(Assignee)

Updated

9 years ago
Summary: TARGET_XPCOM_ABI not set in AIX builds for target_cpu rs6000 → missing support for AIX target in configure.in

Updated

9 years ago
Attachment #334172 - Flags: review?(cls) → review+

Updated

9 years ago
Attachment #334174 - Flags: review?(cls) → review+
(Assignee)

Comment 8

9 years ago
Comment on attachment 334172 [details] [diff] [review]
[checked in on 1.8] clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH

Patch does not affect any platform except AIX.

For AIX I have tested this patch with the releases of FIREFOX_2_0_0_16_RELEASE, THUNDERBIRD_2_0_0_16_RELEASE,
SEAMONKEY_1_1_11_RELEASE
and yesterday on MOZILLA_1_8_BRANCH successfully
Attachment #334172 - Flags: approval1.8.1.17?
(Assignee)

Comment 9

9 years ago
Comment on attachment 334174 [details] [diff] [review]
set XPCOMABI on AIX and raise minimum compiler version CVS HEAD

This one should go the usual way: first on trunk and perhaps later back to 1.9.0 branch. 
Isn't urgent as there is still no successful AIX build of trunk now and in the next few weeks.
(Assignee)

Updated

9 years ago
Version: unspecified → 1.8 Branch
(Assignee)

Updated

9 years ago
Duplicate of this bug: 332075
Keywords: checkin-needed
Comment on attachment 334172 [details] [diff] [review]
[checked in on 1.8] clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH

Approved for 1.8.1.17, a=dveditz for release-drivers.

But code-freeze is coming up and you're not around so this might actually have to wait until the next release.
Attachment #334172 - Flags: approval1.8.1.17? → approval1.8.1.17+
(Assignee)

Comment 12

9 years ago
(In reply to comment #11)
> (From update of attachment 334172 [details] [diff] [review])
> Approved for 1.8.1.17, a=dveditz for release-drivers.
> 
> But code-freeze is coming up and you're not around so this might actually have
> to wait until the next release.
> 

I will release my Firefox for AIX builds with this patch applied on my local build  machine when I'm back. 
I would prefer it in 1.8.1.18, so I'm on hook when checked-in.
Comment on attachment 334172 [details] [diff] [review]
[checked in on 1.8] clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH

Alright, just request approval when the flag appears in a week or two.
Attachment #334172 - Flags: approval1.8.1.17+
(Assignee)

Updated

9 years ago
Attachment #334174 - Flags: approval1.9.0.3?
(Assignee)

Updated

9 years ago
Attachment #334172 - Flags: approval1.8.1.18?
(Assignee)

Comment 14

9 years ago
Requesting branch approval for attachment 334172 [details] [diff] [review] for 1.8.1.18

I have built rc2 of FIREFOX 2.0.0.17 and SEAMONKEY 1.1.12 on AIX 4.3.3 and AIX 5.1 with the patch locally applied. All works like expected. No other platforms except AIX are affected by this patch.
(Assignee)

Updated

9 years ago
Flags: blocking1.8.1.18?
not blocking but we'll look at the approval requests when the tree reopens.
Flags: blocking1.8.1.18?
Keywords: checkin-needed
Whiteboard: [c-n: which patch, where ?]
(Assignee)

Comment 16

9 years ago
Requesting branch approval for attachment 334174 [details] [diff] [review] for 1.9.0.3
(Assignee)

Updated

9 years ago
Attachment #334172 - Attachment description: clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX → clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH
Comment on attachment 334172 [details] [diff] [review]
[checked in on 1.8] clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH

Approved for 1.8.1.18, a=dveditz for release-drivers
Attachment #334172 - Flags: approval1.8.1.18? → approval1.8.1.18+
Comment on attachment 334174 [details] [diff] [review]
set XPCOMABI on AIX and raise minimum compiler version CVS HEAD

Approved for 1.9.0.3, a=dveditz for release-drivers
Attachment #334174 - Flags: approval1.9.0.3? → approval1.9.0.3+
(Assignee)

Updated

9 years ago
Attachment #334174 - Attachment description: set XPCOMABI on AIX and raise minimum compiler version → set XPCOMABI on AIX and raise minimum compiler version CVS HEAD
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Whiteboard: [c-n: which patch, where ?]
(Assignee)

Updated

9 years ago
Whiteboard: c-n only one patch per branch as approved by dveditz
(Assignee)

Updated

9 years ago
Whiteboard: c-n only one patch per branch as approved by dveditz → [c-n: 1.8.1 branch only] [c-n: 1.9.0 branch only]

Comment 19

9 years ago
Comment on attachment 334172 [details] [diff] [review]
[checked in on 1.8] clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH

MOZILLA_1_8_BRANCH: Checking in configure.in;
/cvsroot/mozilla/configure.in,v  <--  configure.in
new revision: 1.1503.2.112; previous revision: 1.1503.2.111
done
Attachment #334172 - Attachment description: clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH → [checked in on 1.8] clear MOZ_FIX_LINK_PATH + set XPCOMABI on AIX MOZILLA_1_8_BRANCH

Updated

9 years ago
Keywords: fixed1.8.1.18
Whiteboard: [c-n: 1.8.1 branch only] [c-n: 1.9.0 branch only] → [c-n: 1.9.0 branch only]
(Assignee)

Comment 20

9 years ago
Change Version to 1.9.0 branch after checkin to branch 1.8
Version: 1.8 Branch → 1.9.0 Branch
CVS HEAD:

Checking in configure.in;
/cvsroot/mozilla/configure.in,v  <--  configure.in
new revision: 1.1999; previous revision: 1.1998
done
Keywords: fixed1.9.0.4
Whiteboard: [c-n: 1.9.0 branch only]
http://hg.mozilla.org/mozilla-central/rev/e91993a18426
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b2
Version: 1.9.0 Branch → unspecified
(Assignee)

Updated

9 years ago
Keywords: fixed1.8.1.18 → verified1.8.1.18
You need to log in before you can comment on or make changes to this bug.