Google search plugins localization

RESOLVED WORKSFORME

Status

()

Firefox
Search
--
minor
RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: Sebastien Marinier, Unassigned)

Tracking

3.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; fr; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

The Google search plugins is always in english by default. It should used the localization setup from Firefox.

Reproducible: Always

Steps to Reproduce:
1. Type a search in the search box (top right)
2. Results are in google.com
3.


Expected Results:  
Localized results (as the Home Page from Firefox)

In the google.xml (searchplugins folder), the suggestions use the correct localization : "hl={moz:locale}".

So i add 
<Param name="hl" value="{moz:locale}"/>

in google.xml, and it works (at least in french). I suggest to update google.xml with this modification.
Strange... As far as I know, Google search plugin is the same for all locales: if I search something with that searchplugin, results are displayed from google.it (I'm using the Italian version of Firefox), not from google.com

If you create a new profile the behaviour is the same?
(Reporter)

Comment 2

10 years ago
In fact, this is all handled by Google cookies. If you click once (what i've done) on "Google.com in English", all yours calls to google.com will be handled in english, including the search from Firefox (wich is based on google.com).
The parameter rls=org.mozilla:fr:official doesn't affect the google localization.

As the suggestions Url use the correct "hl", i maintain my suggestion to localize the search.
Stas, can you enlighten us?

Comment 4

9 years ago
The suggest hl selection is to actually get a specific corpus for suggest.

We're not passing an hl for search because that's what google considers to be the right thing for their search experience.

I guess it can't hurt to occasionally check back on whether we're still making the right call here. Kev?

In general, though, I think that the default locale selection plus cookie behaviour is gonna be right for most of our users, and I don't know if there's a way to overwrite hl by user choice if we add it to the plugin. If there isn't, it'd suck to add it, IMHO.
Lets confirm it for now to get the unconfirmed list cleaner.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: PowerPC → All
Version: unspecified → 3.0 Branch
(Reporter)

Comment 6

9 years ago
Google changed the way it handles Firefox queries. So, one year later, this proposition is now obsolete (don't know when they change it, as is used my modified search plugins). Thanks to Google.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.