Closed Bug 451033 Opened 13 years ago Closed 13 years ago

firefox has 32767 pixels limit for wide element

Categories

(Core :: Layout: Block and Inline, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 215055

People

(Reporter: jianma, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322; InfoPath.2; MS-RTC LM 8; .NET CLR 3.5.21022; CIBA)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a2pre) Gecko/20080817033619 Minefield/3.1a2pre

if the container has very big width. e.g. 60000px
when the content element has a "Left" style which exceeds 32767px, it will not get shown.

If its Left < 32767px and (its Left + its width) > 32767px, it will get partially shown.

I'll upload test html file for it.

Reproducible: Always

Steps to Reproduce:
1.see the repro html file: test.html
2.
3.
Actual Results:  
partially shown element and not shown element

Expected Results:  
fully shown as IE and Safari do.
Attached file testcase test.html
I can see both divs on Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1 and on a recent mozilla-central build.
However, the issue you are experiencing is likely to be a duplicate of bug 215055, as gecko does not handle coordinates larger than 16bits very well.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
You need to log in before you can comment on or make changes to this bug.