Invalid handling comment tag if xhtml doctype declared

RESOLVED DUPLICATE of bug 214476

Status

()

--
minor
RESOLVED DUPLICATE of bug 214476
10 years ago
10 years ago

People

(Reporter: skyh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Invalid handling comment tag if xhtml doctype declared, but file is html (or mime type is "text/html")

Reproducible: Always

Steps to Reproduce:
Create sample test.html page than contains data like this:


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head><title></title></head>
<body>
  <!--
    --this is invalid comment in xhtml
  -->
</body>
</html>
Actual Results:  
comment will be displayed

Expected Results:  
blank page
(Reporter)

Updated

10 years ago
Keywords: xhtml
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: xhtml
Resolution: --- → DUPLICATE
Duplicate of bug: 214476
You need to log in before you can comment on or make changes to this bug.