Cache eviction is broken when large cache size is set preventing further caching

RESOLVED DUPLICATE of bug 175600

Status

()

--
major
RESOLVED DUPLICATE of bug 175600
10 years ago
8 years ago

People

(Reporter: me, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When you set your cache to be very large (say 2048mb) but fill the cache map entries with smaller items so no item will ever be evicted due to taking up too much space, caching still stop.
 




Reproducible: Always

Steps to Reproduce:
clear your cache the old fashioned way be deleting all the files from the
profile folder:

now, in the gui, tools > options > advanced > networks > offline storage > enter a really big number here like 2000 mb.

surf to http://favicoop.com/ to fill up the cache object entries, keep surfing
until the about:cache tells you that you've got 8192 items in the cache, or as
close as it will go.

now visit another site which is normally cachable, but isn't currently cached.

right click an image, select properties and note how firefox hasn't cached it
Actual Results:  
Caching will stop

Expected Results:  
an object should be evicted from the cache to make way for new content.

Updated

10 years ago
Keywords: perf
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Comment 1

9 years ago
Mark, you set bug report = version 3. did this work differently for you in version 2?
Component: General → Networking: Cache
Product: Firefox → Core
QA Contact: general → networking.cache
Version: 3.0 Branch → unspecified

Comment 2

9 years ago
dupe to bug 524232?
(In reply to comment #0)
> the about:cache tells you that you've got 8192 items in the cache, (snip)

Bug 175600?
> Bug 175600 Only 8192 objects can be stored in disk cache.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 175600
You need to log in before you can comment on or make changes to this bug.