1 bug, many warning fixes in nsSeaMonkeyMigrator.cpp

RESOLVED FIXED in Firefox 3.1a2

Status

()

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: mrbkap, Assigned: mrbkap)

Tracking

unspecified
Firefox 3.1a2
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:413: warning: missing braces around initializer for ‘nsNetscapeProfileMigratorBase::PrefTransform::<anonymous union>’
nsDogbertProfileMigrator.cpp
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp: In member function ‘nsresult nsSeamonkeyProfileMigrator::CopyPasswords(PRBool)’:
/home/mrbkap/work/opt/mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp:684: warning: ‘rv’ may be used uninitialized in this function

The last warning is a real bug. The first many warnings are annoying and easy to fix.
Created attachment 334514 [details] [diff] [review]
Fix
Assignee: nobody → mrbkap
Status: NEW → ASSIGNED
Attachment #334514 - Flags: review?(gavin.sharp)
Attachment #334514 - Flags: review?(gavin.sharp) → review+
That bug might be the cause of bug 441630, fwiw (see my comment there).

Comment 3

10 years ago
pushed to mozilla-central: http://hg.mozilla.org/mozilla-central/index.cgi/rev/3c09b73c94ed
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a2
You need to log in before you can comment on or make changes to this bug.