Open Bug 451254 Opened 15 years ago Updated 2 months ago

Selection problems with xbl anonymous text and normal text

Categories

(Core :: DOM: Selection, defect)

x86
Windows XP
defect

Tracking

()

REOPENED

People

(Reporter: martijn.martijn, Unassigned)

Details

(Keywords: testcase)

Attachments

(2 files, 1 obsolete file)

See upcoming testcase.

When drag-selecting from left to right, it seems all text gets selected, but that's not the case. As soon as the xbl anonymous content gets selected, the normal text is not selected anymore. The problem is that the selection is not unpainted as it should be. When you hover over the repaint button, you see the selection disappear.
Attached file testcase (obsolete) —
Attached file testcase
Attachment #334564 - Attachment is obsolete: true
problem is probably deeper since selection disappears on normal elements as well
just starting selection and moving slowly causes selection to disappear in one  out of 20-30 cases
 usually this happens when mouse crosses boundary between text nodes and other elements
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Severity: minor → S4
You need to log in before you can comment on or make changes to this bug.