Pushbuttons don't depress on mouse click

VERIFIED DUPLICATE of bug 49273

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 49273
18 years ago
15 years ago

People

(Reporter: Hyman Rosen, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; m17)
Gecko/20000710
BuildID:    2000071020

Press and hold the left mouse button over a pushbutton, say the
'See bugs in this
component' button. The button does not assume its
depressed look until another event
occurs, say moving the mouse
slightly.

Reproducible: Always
Steps to Reproduce:
1.Move mouse cursor over pushbutton.
2.Press and
hold left button without moving mouse.
3.Now move mouse slightly.

Actual Results:  1. A solid
outline appears around the button.
2. A dashed outline appears inside the button.
3. The button
insides shift right and down to look depressed.

Expected Results:  The step 3 results should
happen in step 2.

Comment 1

18 years ago
With 2000071108 linux (rh6.1), I am not seeing this at all. The button will 
depress on the 'click' event, and the 'mousemove' produces no additional
change in the visual appearance of the button. Can you check this again, or
add some additional details on how to reproduce

-> rods, HTML Form Controls, but this may be worksforme
Assignee: trudelle → rods
QA Contact: jrgm → ckritzer
(Reporter)

Comment 2

18 years ago
I'm running on Debian (unstable), and the behavior is just as I described,
and has been that way for as long as I can remember. I don't know what else
to tell you, but I'll be happy to supply more information if you tell me what
you want to know.

Comment 3

18 years ago
I also don't see this on Linux (Red Hat 6.2, Gnome 1.2) 2000071108.
(Reporter)

Comment 4

18 years ago
OK, now I have more information, and I don't think it's a Mozilla bug.
I see this behavior when I am running the Enlightenment window manager.
When I run Mozilla alone with no WM, it works fine. Sorry for the false
alarm.

Comment 5

18 years ago
Marking INVALID based on reporter's comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 6

18 years ago
actually, it could still be a mozilla bug (not too likely, though).  reporter, 
are you still seeing this with new nightly builds?
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

18 years ago
Yes, it's still present. And upon further reflection, I think it must
in fact be a Mozilla bug, because I don't see it happening when I use
Netscape (the old one). Then buttons depress when I click on them, and
I don't have to jiggle the mouse.
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 8

18 years ago
There is a bug filed, I believe, where a certain option on some WM's will
conflict with the button being "depressed" onclick, observed for buttons
in the UI (XUL). bug 49273. 

This bug was reported against HTML Form Controls, but quite likely it's the
same bug.

Comment 9

17 years ago
hymie@prolifics.com:
Since you report this differently with different WM, I believe that this is the
same problem (some type of click-trapping behavior) reported and better
documented in 49273. I'm marking this as a dup. If you feel strongly otherwise,
post to the bug and we can re-open.

*** This bug has been marked as a duplicate of 49273 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
small atomic mass update:
qacontact->jrgm
QA Contact: ckritzer → jrgm

Comment 11

17 years ago
vfy duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.