Closed Bug 451560 Opened 13 years ago Closed 13 years ago

Firefox holds open filehandle for files uploaded via forms

Categories

(Firefox :: File Handling, defect)

3.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 183689

People

(Reporter: bugzilla, Unassigned)

Details

Just noticed this one; Firefox seems to hold open a filehandle for any file I try to upload to a form; it even seems to open a new one if I upload the same file twice, meaning it can hold open many filehandles to the same file!  This obviously prevents you renaming, deleting, etc. the file; Firefox should release the filehandle immediately.

To reproduce, go to:
http://library.loudoun.gov/Default.aspx?tabid=278

type in a@b.com as email address, upload a file (I uploaded a simple .csv).

Use Process Explorer NT to check for open handles to that filename.  Firefox should be holding open a handle to that file.

My FF build ID:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Version: unspecified → 3.0 Branch
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 183689
You need to log in before you can comment on or make changes to this bug.