Previews in ctrl-tab/all-tabs panel are not updated consistently (empty or outdated image)

VERIFIED FIXED in Firefox 3.1b1

Status

()

defect
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: whimboo, Assigned: dao)

Tracking

Trunk
Firefox 3.1b1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a2pre) Gecko/20080821020645 Minefield/3.1a2pre ID:20080821020645

In some situations the preview images are not updated and show no or an outdated image.

Use the following STR to see an empty (not updated from blank tab) preview:
1. Open Firefox with one tab open and e.g. the homepage loaded
2. Click Cmd+T/Ctrl+T twice to get three tabs
3. Open the homepage within the 3rd tab
4. Press Ctrl+Tab to switch to the second tab
=> Verify that both previews are shown
5. Open the homepage within the 2nd tab
6. Press Ctrl+Tab to switch back to the 3rd tab
=> Verify that for the current active tab there is no preview shown
7. Press again Ctrl+Tab
=> Verify that all previews are shown

Even when navigating through pages the previews are not updated:
1. Repeat steps 1-6 from the above STR
2. Click on any URL which is referenced from your homepage
3. Wait until the target page is loaded and press Ctrl+Tab
=> Verify that the preview still shows the capture from the homepage

This is reproducibly on Windows and OS X.
Sorry, I forgot that this also happens for the upcoming all-tabs panel. I have tested the tryserver build mentioned in bug 436304 comment 24. I'll attach a screenshot.
Blocks: 436304
Summary: Previews in ctrl-tab panel are not updated consistently (empty or outdated image) → Previews in ctrl-tab/all-tabs panel are not updated consistently (empty or outdated image)
As you can see Gmail is opened in background and the preview still shows the google start page while the title says "Google Mail". It can be reproduced by the first given STR.
(Assignee)

Comment 3

11 years ago
Posted patch patchSplinter Review
simply invalidate previews if the location has changed
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #335022 - Flags: review?(gavin.sharp)
Attachment #335022 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
(Assignee)

Comment 4

11 years ago
http://hg.mozilla.org/mozilla-central/rev/bb8cfffef4a9
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b1
test please?
Flags: in-testsuite?
Verified with Ctrl-Tab and following builds:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080901033305 Minefield/3.1b1pre ID:20080901033305

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080901020926 Minefield/3.1b1pre ID:20080901020926
Status: RESOLVED → VERIFIED
Duplicate of this bug: 447889
You need to log in before you can comment on or make changes to this bug.