filename incomplete when downloading files with spaces in the filename

VERIFIED DUPLICATE of bug 221028

Status

()

VERIFIED DUPLICATE of bug 221028
11 years ago
11 years ago

People

(Reporter: HMWiesinger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

If you download a file named for example "http://www.test.com/Report May 2008.pdf", the download link in the statusbar will be displayed the same way. However, the dialog which shows up to select whether you want to open or save the file, displays the filename just as "Report". The download of the file will work, but all characters after the first space are omitted.
This is especially a problem on windows where the program to open a file is determined on the file-extension which is then missing.

Reproducible: Always

Steps to Reproduce:
1.Download a file with spaces in the filename
2.select save
3.view the incomplete filename (in the save dialog as well as in the filesystem)
Actual Results:  
file was alright, opening (after renaming) did work, filename incomplete

Expected Results:  
save the file with the complete filename
Example URL ?
(Reporter)

Comment 2

11 years ago
Alright, my mistake. Should have tested this more carefully. It does work fine with direct links to the files. However, I use indirect downloading of the file, meaning I use a script to download the file from another location. I can provide an example download here:

http://www.liwjatan.at/download.php5?project=src&filename=slack%20new.bmp

I tested this in Konqueror-3.5.9, firefox-3.0.1, Internet Explorer 8beta and Opera 9.51, with firefox being the only one who truncates the filename.

Comment 3

11 years ago
web-sniffer.net says that URL returns

'Content-Disposition: attachment; filename=slack new.bmp'
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 221028
damn, jesse was faster.
I expected the broken content-disposition header, that's the reason why I asked for a URL :-)

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.