Closed Bug 451724 Opened 12 years ago Closed 12 years ago

Trying to print page as PDF results in crash

Categories

(Firefox :: Menus, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jboriss, Unassigned)

Details

Whenever I try to save a page as a PDF through the print dialog, Firefox stalls and crashes, requiring a force quit.

Steps to reproduce:
1. Go to File, drag to Print
2. Click on PDF, drag to "Save as PDF"

Expected result:
Dialog page appears where you can specify PDF presferences

Actual result: 
Firefox freezes.  After about 5 seconds cursor turns to pinwheel, and Firefox will remain frozen.
I can't reproduce this, either in FF 3.0.1 or in a recent trunk (aka
1.9.1-branch) nightly (from 2008-09-03).

Extensions problem?  Does it happen when you start Firefox in Safe
Mode (hold Option while starting Firefox)?

System problem?  Does it also happen in Safari?
Boriss, any more information here? Without information we can't get this fixed...
I can no longer reproduce this on my own machine with a build or release since updating OSX.  Must have been my computer or the OS.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Changing to WORKSFORME since there was no code change involved...
Resolution: FIXED → WORKSFORME
I'm experiencing this problem. Whenever I try to print to pdf it crashes Firefox.
Please post the version of Firefox that you are using when you crash, as well as the Crash ID which you can get from typing about:crashes in the URL bar.

(In reply to comment #5)
> I'm experiencing this problem. Whenever I try to print to pdf it crashes
> Firefox.
Sorry, can't get the crash information.
It just seizes up, both adobe and mozilla.

Firefox version is 3.0.3
ray: that's not a crash. it's a hang.

http://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

!analyze -v -hang
You need to log in before you can comment on or make changes to this bug.