If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Flash (SWF) content not being rendered with strict XHTML Object

RESOLVED DUPLICATE of bug 254483

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 254483
9 years ago
9 years ago

People

(Reporter: Andre-John Mas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

I have created a test html file, based on the SWF content found here:

http://www.nytimes.com/interactive/2008/08/21/sports/olympics/20080821_10M_DIVING.html

Taking the mentioned resources adding them to a strict XHTML document I find that the content renders in Safari and in Opera, but not in Firefox 3.0.1. Checking various documentation the following XHTML would appear to be correct, so I am suspecting Firefox is doing something different to the other two browsers:

<object type="application/x-shockwave-flash"
        classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
        data="http://www.nytimes.com/packages/flash/multimedia/swfs/AS3Multiloader.swf"
        style="width: 950px; height: 545px; background-color: #eeeeff"
        width="950px" height="545px">

   <param name="flashvars"
          value="panoPath=http://graphics8.nytimes.com/packages/flash/sports/olympics/2008/20080821_10M_PANO/CUBE10mPLATFORMpanoA.jpg&amp;narrationPath=http://graphics8.nytimes.com/packages/flash/sports/olympics/2008/20080821_10M_PANO/watercube_finchum.mp3&amp;enableFullScreen=true&amp;initXRotation=-12&amp;initYRotation=82&amp;contentPath=http://graphics8.nytimes.com/packages/flash/multimedia/TEMPLATES/Pano/pano.swf"/>

</object>

Saving the files locally and serving them from a local web server (adjusting URLs as necessary) does not change the results.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

9 years ago
Created attachment 335079 [details]
HTML file showing the issue

Have added a test case in the form of an HTML file.

Note I have validated that this is valid XHTML with: http://validator.w3.org/
(Reporter)

Comment 2

9 years ago
Created attachment 335081 [details]
New version of the test case

I have attached a new test case. This new version of the test case works with IE6, Opera 9.5 and Safari 3, but fails with Firefox 3.0.1. All these were tested on Windows XP.
(Reporter)

Updated

9 years ago
Summary: Flash content not being rendered with strict XHTML Object → Flash (SWF) content not being rendered with strict XHTML Object
Comment on attachment 335081 [details]
New version of the test case

If you want xhtml then you must serv it with the right mime-type application/xhtml+xml
Attachment #335081 - Attachment mime type: text/html → application/xhtml+xml
(Reporter)

Comment 4

9 years ago
I am loading this file locally, so there no notion of server. The file specifies the DOCTYPE, which should be enough based on existing documentation. Additionally I have just tried adding:

<meta http-equiv="Content-Type" content="application/xhtml+xml" />

and this changes nothing.
(Reporter)

Comment 5

9 years ago
In response to comment 3: the modified mime-type provided to the attached test case changes nothing in regards to the issue. Just tested with the four browsers in question. Firefox 3.0.1 still fails.
(Reporter)

Comment 6

9 years ago
I have just given the attachment 335081 [details] (New version of the test case) on MacOS X 10.5. Results:
  - Works in Safari
  - Works in Opera
  - Fails in Firefox

For this reason I have changed this to all platforms. This is a blocker to properly formed strict XHTML.
Severity: normal → major
OS: Windows XP → All
Hardware: PC → All
>        classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"

That tells us that you only accept the ActiveX Flash implementation.  Since we can't use that plug-in (no one except IE can), we fall back to the fallback content, as required in the HTML4 specification.  Just taking this out will make things work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254483
(Reporter)

Comment 8

9 years ago
Removing the classid indeed seems to solve the issue.
You need to log in before you can comment on or make changes to this bug.