Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Allow matching at beginning of title/url by pref

VERIFIED FIXED in Firefox 3.1a2

Status

()

Firefox
Location Bar
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Mardak, Assigned: Mardak)

Tracking

Trunk
Firefox 3.1a2
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Firefox 3.1 already supports ways to match only urls and visited history, so the main thing missing behavior of Firefox 2 is matching only at the beginning.

We already have browser.urlbar.matchBehavior to indicate to match anywhere or match on boundaries, so it'll be easy to make it specify to match at the beginning.
(Assignee)

Comment 1

9 years ago
Created attachment 335096 [details] [diff] [review]
v1

matchBehavior of 3 will only match at the beginning. Testcase tests positive and negative matches as well as a sanity check.
Assignee: nobody → edilee
Status: NEW → ASSIGNED
Attachment #335096 - Flags: review?(dietrich)
Comment on attachment 335096 [details] [diff] [review]
v1

r=me, thanks
Attachment #335096 - Flags: review?(dietrich) → review+
(Assignee)

Comment 3

9 years ago
http://hg.mozilla.org/mozilla-central/index.cgi/rev/4a054a681d76
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a2

Updated

9 years ago
Blocks: 434267
Verified FIXED using the pref setting in comment 0; substrings with that pref set to "3" fail to be found, with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b1pre) Gecko/20080911135921 Minefield/3.1b1pre

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080911105329 Minefield/3.1b1pre

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080911020347 Minefield/3.1b1pr
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 461428

Comment 6

9 years ago
I use Win-XP Pro and Firefox 3.0.5 -- just checked for updates -- none shown
I have set the following in about:config

browser.urlbar.matchBehavior .. 3
browser.urlbar.matchOnlyTyped .. true

however, typing in just fi also brings up about:conFIig

Have I missed something?

Comment 7

9 years ago
(In reply to comment #6)
> I use Win-XP Pro and Firefox 3.0.5 -- just checked for updates -- none shown
> I have set the following in about:config
> 
> browser.urlbar.matchBehavior .. 3
> browser.urlbar.matchOnlyTyped .. true
> 
> however, typing in just fi also brings up about:conFIig
> 
> Have I missed something?


Yes, I believe this pref is in 3.1 but not 3.0
(3.1 not being a stable release yet wouldn't show up as an update to 3.0)
You need to log in before you can comment on or make changes to this bug.