Closed Bug 451827 Opened 15 years ago Closed 15 years ago

Update to build 2008082219 -> no local storage calendar, error at startup

Categories

(Calendar :: General, defect)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: ssitter)

References

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- create a new profile
- install lightning 2008082118
- update this profile with lightning 2008082218
- restart thunderbird/lightnin

RESULT:
=======

- Error message at startup
- error console output:

Error: [Exception... "'Failure' when calling method: [calICalendar::uri]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js :: cmgr_createCalendar :: line 536"  data: no]
Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 536

Error: Assert failed: An error was encountered preparing the calendar located at moz-profile-calendar:// for use. It will not be available.
1: [file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js:1004] ASSERT
2: [file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js:560] cmgr_createCalendar
3: [file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js:704] cmgr_assureCache
4: [file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js:680] cmgr_getCalendars
5: [null:0] null

Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js
Line: 1009

Error: [Exception... "'Failure' when calling method: [calICalendar::uri]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js :: cmgr_createCalendar :: line 536"  data: no]
Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 536

Error: Assert failed: An error was encountered preparing the calendar located at moz-profile-calendar:// for use. It will not be available.
1: [file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js:1004] ASSERT
2: [file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js:560] cmgr_createCalendar
3: [null:0] null
4: [chrome://calendar/content/calendar-management.js:113] loadCalendarManager
5: [chrome://calendar/content/calendar-chrome-startup.js:43] commonInitCalendar

Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js
Line: 1009

Error: calendar has no properties
Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 580

Error: calendar has no properties
Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 580

Error: [Exception... "'Failure' when calling method: [calICalendar::uri]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js :: cmgr_createCalendar :: line 536"  data: no]
Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 536

Error: Assert failed: An error was encountered preparing the calendar located at moz-profile-calendar:// for use. It will not be available.
1: [file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js:1004] ASSERT
2: [file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js:560] cmgr_createCalendar
3: [null:0] null
4: [chrome://calendar/content/calendar-management.js:113] loadCalendarManager
5: [chrome://calendar/content/calendar-chrome-startup.js:43] commonInitCalendar

Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js
Line: 1009

Error: calendar has no properties
Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 580

Error: calendar has no properties
Source File: file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/nord/.thunderbird/8aiffzm4.2108/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 580

Error: calendar has no properties
Source File: chrome://calendar/content/calendar-task-editing.js
Line: 107

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIWebNavigation.loadURI]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://global/content/viewSource.js :: viewSource :: line 141"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIWebNavigation.loadURI]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://global/content/viewSource.js :: viewSource :: line 141"  data: no]

EXPECTED RESULT:
================

- no errors, local sorage calendar should be visible/usable
- it shoud be possible to create a new local storage calendar

REPRODUCIBLE:
=============

- always
Flags: blocking-calendar0.9?
Blocks: 446303
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #335166 - Flags: review?(daniel.boelzle)
Comment on attachment 335166 [details] [diff] [review]
[checked in] enable database upgrade to schema version 14

r=dbo, checked in on HEAD and MOZILLA_1_8_BRANCH
Attachment #335166 - Attachment description: enable database upgrade to schema version 14 → [checked in] enable database upgrade to schema version 14
Attachment #335166 - Flags: review?(daniel.boelzle) → review+
Flags: in-litmus-
Flags: blocking-calendar0.9?
Flags: blocking-calendar0.9+
Target Milestone: --- → 0.9
Summary: Update lighning with xpi build 2008082219 -> no local storage calendar, error at startup → Update to build 2008082219 -> no local storage calendar, error at startup
Is this one fixed?
Flags: in-litmus-
I'd say it should be fixed by the checked-in patch when running the next nightly build containing the patch.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> Is this one fixed?

(In reply to comment #6)
> I'd say it should be fixed by the checked-in patch when running the next
> nightly build containing the patch.

Linux and Windows tinderboxen are down or hang, so we have no recent nightly builds to check if the issue is fixed.
I checked this issue with lightning 2008082503 at Solaris Sparc/X86 and Mac, bug is fixed.

I mark this issue VERIFIED.
Status: RESOLVED → VERIFIED
(In reply to comment #7)
> (In reply to comment #5)
> > Is this one fixed?
> 
> (In reply to comment #6)
> > I'd say it should be fixed by the checked-in patch when running the next
> > nightly build containing the patch.
> 
> Linux and Windows tinderboxen are down or hang, so we have no recent nightly
> builds to check if the issue is fixed.
> 

It is already August 26th and there hasn't been a build available for Linux since the August 22nd build.  When will a build be available that fixes this issue?  
(In reply to comment #9)
Once Bug 451968 is fixed and the build server are back online.
(In reply to comment #10)
> (In reply to comment #9)
> Once Bug 451968 is fixed and the build server are back online.
> 

Is there a workaround in the meantime?
"Verified Fixed"?? Upgraded from Lightning 0.9 to the latest development version:

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.createTable]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/HOME/tps/Application%20Data/Thunderbird/Profiles/release.Default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendarModule.js -> file:///C:/HOME/tps/Application%20Data/Thunderbird/Profiles/release.Default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calStorageCalendar.js :: anonymous :: line 1236"  data: no]

local calendar "moz-profile-calendar://?id=2" could not be opened. All remote calendars are available. Only the local ones are not.
(In reply to comment #12)
With latest development version you mean the builds for Thunderbird 3? Update to Trunk is not yet fully supported and has known database issues, see e.g. Bug 455358. Please file new bugs for new issues.
No, those for Thunderbird 2.0.0.16 (20080708).
Lightning Trunk builds report themselves as Version 0.6a
You need to log in before you can comment on or make changes to this bug.