Closed Bug 452016 Opened 13 years ago Closed 13 years ago

Uploaded files are kept opened forever

Categories

(Firefox :: General, defect)

x86
Windows Server 2003
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 183689

People

(Reporter: vz-mozilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When uploading a file using a form with the following field:

<INPUT TYPE="file" NAME="topic_file" VALUE="" SIZE=40 MAXLENGTH=200 />

the file being uploaded is kept opened by Firefox seemingly forever (at least 48 hours here), even after leaving the upload form and closing the tab it was in. This means that the file can't be deleted before you close the browser which is pretty annoying.

The file is definitely kept opened by Firefox as can be seen using a tool like Process Explorer (http://live.sysinternals.com/procexp.exe): FF process has an opened handle (with reference count of 1) for this file.


Reproducible: Always

Steps to Reproduce:
1. I am using CodeStriker (http://codestriker.sourceforge.net/index.html)
2. I use "Create Topic" in its interface which shows the form with the file upload field
3. I use it to select any file
4. Then I submit the form
5. Then I try to delete the file -- this fails with "this file is being used by another application" error.

I don't believe CodeStriker is critical to reproducing this, I simply don't have any other file upload form at hand. Looking at the opened file handles list in my (long running) instance of Firefox I can see several files which were uploaded to completely different pages (e.g. Trac instances, SourceForge, ...) so it seems like the problem is not specific to CodeStriker at all.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 183689
You need to log in before you can comment on or make changes to this bug.