Open menus are not rolled up when alert or dialog comes up.

VERIFIED FIXED in mozilla1.0

Status

()

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: jrgmorrison, Assigned: mikepinkerton)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nsbeta3-)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Overview Description:
  Open menus are not rolled up when alert or dialog comes up.

Steps to Reproduce:

Load the attached test case. The test document will throw up an
alert() 10 seconds after it is loaded.

Tests: 
(1) Open a top-level menu (e.g. File), and mouseover an item in the
    list, or
(2) open the <select> in the body of the page, and mouseover an
    item in the list, or
(3) bring up a context menu in the browser, and mouseover an item in
    the list.

Then wait for the alert to fire. (A countdown is displayed in
window.status).

Actual Results:

  On mac, the open menu is rolled up when the alert comes up[1]. 

  On win32 and linux, the menu stays unrolled and active when the
  alert comes up.

([1] actually, on mac, for the purely native menus, the javascript
countdown blocks while the top-level menu is open and the alert is
never thrown up while the menu is open, but that's a different issue.)

Expected Results: 
  Menus should rollup when a dialog comes up.

Reproducibility: always on win32/linux for top-level menus, context
                 menus, and HTML select.

Build Date & Platform Bug Found:
  2000071108 win95
  2000071108 linux

Additional Builds and Platforms Tested On:
  WORKS ~CORRECTLY for 2000071108 mac
(Reporter)

Comment 1

19 years ago
Created attachment 11265 [details]
testcase; document that fires an alert on a 10-second delay
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M21
(Assignee)

Updated

19 years ago
Keywords: nsbeta3

Comment 2

19 years ago
nsbeta3-, unusual, but nothing bad happens
Whiteboard: nsbeta3-
(Assignee)

Updated

19 years ago
Target Milestone: M21 → Future

Comment 3

18 years ago
This sounds an awful lot like bug 45108.
(Assignee)

Updated

18 years ago
Target Milestone: Future → mozilla1.0

Updated

18 years ago
Depends on: 45108

Comment 4

18 years ago
Marking dependent on 45108.  I'm almost positive that these are the exact same 
behavior, but I don't want to mark them as dupes.

Comment 5

18 years ago
What I said in 45108 makes sense for this as well, and the patch seems to fix 
it.
(Assignee)

Comment 6

18 years ago
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
verified, using testcase and 2001051704
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.