Closed Bug 452046 Opened 13 years ago Closed 13 years ago

Compose/Reply broken in SeaMonkey MailNews

Categories

(SeaMonkey :: MailNews: Composition, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mcsmurf, Assigned: iann_bugzilla)

References

Details

To reproduce:
1. Fetch trunk build
2. Try to compose a mail

Results:
Nothing happens and this error appears in JS Console:
Error: uncaught exception: [Exception... "Could not convert JavaScript argument - 0 was passed, expected object. Did you mean null? arg 4 [nsIMsgComposeService.OpenComposeWindow]"  nsresult: "0x80570035 (NS_ERROR_XPC_BAD_CONVERT_JS_ZERO_ISNOT_NULL)"  location: "JS frame :: chrome://messenger/content/mailCommands.js :: ComposeMessage :: line 255"  data: no]

One thing I found while taking a quick look at the code was is that the call unter http://hg.mozilla.org/comm-central/index.cgi/annotate/0137db13395c/mailnews/base/resources/content/mailOverlay.xul#l33 has eight parameters, not seven. Maybe this is the cause of this bug here (fallout from Bug 366482).
I can't reproduce this using:

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080825002620 Mnenhy/0.7.5.20005 SeaMonkey/2.0a1pre

With this Build I have composed new E-Mail Messages, replied to some, and replied in Newsgroups too, everything works like expected, no error in Error-Console. 
Hrm, after rebuilding it also works again. I still think though that the code mentioned in Comment 0 is wrong.
I've tried this on latest trunk with no issues:
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080825002620 SeaMonkey/2.0a1pre
But you are correct, it does have too many parameters (though the patch that was reviewed has the right number!)
Thanks for the catch - fixed by http://hg.mozilla.org/comm-central/index.cgi/rev/a508be333305
Status: NEW → ASSIGNED
Assignee: nobody → iann_bugzilla
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.