Problem with menu in CSS and JavaScript (mootools.js)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: witekp777, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Bug Flags:
wanted1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

60.10 KB, text/html
Details
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

SWF films (Firefox, IE and Opera) you can see here: http://www.konto-testowe.cba.pl/firefox/index.html. Menu on-line: http://www.konto-testowe.cba.pl/firefox/menu/index.php. Please try a few times cause sometimes it works.

Reproducible: Sometimes

Steps to Reproduce:
Do the same as in swf files.
Actual Results:  
Menu hides.

Expected Results:  
Look what happens in IE and Opera. In Firefox it should be like that too.
Confirmed on Windows Vista.
Works: 2007092019
Fails: 2007092020
Regression range: http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2007-09-20+18%3A00&maxdate=2007-09-20+21%3A00
seems to be caused by Bug 396099. Looks similar to Bug 436527.
Blocks: 396099
Severity: minor → normal
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Flags: blocking1.9.1?
It's hard to block on this without a testcase; in fact, it probably shouldn't have been confirmed without a testcase.
Flags: blocking1.9.1? → wanted1.9.1+

Updated

10 years ago
Keywords: testcase-wanted

Comment 3

10 years ago
Created attachment 342802 [details]
testcase1

Comment 4

10 years ago
testcase1 from bug description, some kind of reduced.
More reduction seems to reduce repeatability.
STR:
- Move mouse over "Features", menue opens below
- Move mouse over menue: Sometimes menue disapears

If you don't see this, reload (F5 or ctr+F5) one or more times.
So.... I can't seem to reproduce this.  Anything to help that would be lovely.

Comment 6

10 years ago
- move mouse over "Features", menue opens
- move mouse over the menue, sometimes menue disappears. 
  If not, 
- move mouse out and repeat the steps above up to 10x

 If you dont see the bug, reload (F5) and repeat

This certainly reproduces the bug for me.

Updated

10 years ago
Duplicate of this bug: 436527

Comment 8

10 years ago
http://www.diskeysign.com/ from the duplicate uses the same scripts "mootools.js" and "template.js"

It shows the bug nicely: 
- move mouse over "Interiour Sings", menue opens below
- move mouse (fastly) down beyond "Metal Frame Signs"
  menue disappears

Comment 9

10 years ago
See http://mootools.net/
Summary: Problem with menu in CSS and JavaScript → Problem with menu in CSS and JavaScript (mootools.js)

Comment 10

10 years ago
Is it possible that this is a performance issue? I was unable to reproduce the bug in the posted testcase, but I was able to reproduce it on the posted site (http://www.diskeysign.com/) when my cpu usage was near 99%.
Can anyone reproduce this still. The testcases here all WFM.

Comment 12

7 years ago
> Can anyone reproduce this still. The testcases here all WFM.

Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0

Can't reproduce with attachment 342802 [details] and STR of comment 8 on the same machine as in 2008.
-> WFM
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.