Closed Bug 452172 Opened 12 years ago Closed 12 years ago

TM: failed assertion `0' in ExprFilter::insGuard

Categories

(Core :: JavaScript Engine, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, testcase)

./js -j
js> for (var j = 0; j < 4; ++j) { 1.2 && true; }

nanojit/LIR.cpp:853: failed assertion `0'

Given the checkin comment "Assert on bogus always-exit guards" on http://hg.mozilla.org/index.cgi/tracemonkey/rev/80b14ab9032b, I'm guessing Andreas Gal already knows about this problem.
Cool stuff. Really easy fixes. I will jump on these as soon I have nesting/break under control.
I changed the assertion, so it now appears as:

Assertion failed: "need a way to EOT now, since this is trace end": 0 (nanojit/LIR.cpp:868)
WFM on tracemonkey branch.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Summary: failed assertion `0' in ExprFilter::insGuard → TM: failed assertion `0' in ExprFilter::insGuard
You need to log in before you can comment on or make changes to this bug.