Closed Bug 452280 Opened 13 years ago Closed 13 years ago

only one user/password can be save in HTTP auth

Categories

(Firefox :: General, defect)

x86
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 227632

People

(Reporter: dolezallukas, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When I have saved user/password for some HTTP authentification I can not save other one. I open again (unlogged) same page and enter other username and password, I log in and I click on "Save password". Then I logout and I want again to login because of I replace preenter username (first saved) with second username and I hope that correct password will be placed to input and sent to webserver. But sent password is the first password.

In password manager, second username/password isn't at all. 

Reproducible: Always

Steps to Reproduce:
1. save username/password in http auth
2. logout, and go again to login (with http auth)
3. enter new username/password and login, then click "save password" to save it.
4. again logout and again go to login
5. preentered username/password is the first
6. replace username with second one
7. hope that password is correct and click "OK"
8. oops.. login failed
Actual Results:  
second user/password can not be saved.

Expected Results:  
it should save a million user/password combinations for one page. 

i tested only on phpmyadmin application, but HTTP auth dialog is browser job no page job..
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 227632
You need to log in before you can comment on or make changes to this bug.