Last Comment Bug 45240 - HTML presentational elements' styles can be overriden by user styles
: HTML presentational elements' styles can be overriden by user styles
Status: VERIFIED DUPLICATE of bug 2942
: css1, testcase
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: x86 Windows 98
: P3 normal (vote)
: ---
Assigned To: Pierre Saslawsky
: ckritzer (gone)
:
Mentors:
Depends on:
Blocks: 2942
  Show dependency treegraph
 
Reported: 2000-07-12 07:49 PDT by fantasai
Modified: 2000-11-05 08:43 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
HTML Presentational Elements Testcase (1.06 KB, text/html)
2000-07-12 07:50 PDT, fantasai
no flags Details
HTML Presentational Elements Testcase - user stylesheet (593 bytes, text/plain)
2000-07-12 07:52 PDT, fantasai
no flags Details

Description fantasai 2000-07-12 07:49:40 PDT
Overview:

	HTML presentational elements (<B>, <I>, etc.) have their styles set in
	html.css, allowing the user stylesheet to override them. The CSS specs
 	specify that presentational hints from the markup be treated as if it
	were at the top of the author's stylesheet, and thus the user stylesheet
	would not be able to alter these styles without an !important rule.

	CSS1:3.2 - http://www.w3.org/TR/REC-CSS1#cascading-order
	CSS2:6.4.4 - http://www.w3.org/TR/REC-CSS2/cascade.html#q12

Steps to Reproduce, Actual Results, and Expected Results:

	See testcase (to be attached shortly)

Tested on:

	Build for.. the 3rd of July, I think. (I'm on a public comp ATM.)
Comment 1 fantasai 2000-07-12 07:50:59 PDT
Created attachment 11289 [details]
HTML Presentational Elements Testcase
Comment 2 fantasai 2000-07-12 07:52:29 PDT
Created attachment 11290 [details]
HTML Presentational Elements Testcase - user stylesheet
Comment 3 Pierre Saslawsky 2000-07-18 16:19:12 PDT
Closing as dup of bug 2942. I moved your comments and testcase there.


*** This bug has been marked as a duplicate of 2942 ***
Comment 4 Scott Brodmerkle 2000-11-05 08:43:03 PST
Verified dupe.

Note You need to log in before you can comment on or make changes to this bug.