Closed Bug 452487 Opened 13 years ago Closed 13 years ago

Inform the user if Firefox is still running after UI shutdown

Categories

(Firefox :: Bookmarks & History, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 407981

People

(Reporter: volkmarkostka, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/20080826034105 Minefield/3.1a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/20080826034105 Minefield/3.1a2pre

There are lots of complaints lately due to the long shutdown times. I guess most people are irritated that the UI has already disappeared while the database is still shutting down. And restarting firefox during database shutdown can lead to data loss (session store overwritten).
A UI like "Firefox is shutting down. Please wait." may be a short term solution until the database is getting faster.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
i suppose this could be dupe of bug 407981, are you trying to add something dependant on the discussion in that bug?
Summary: Life sign during long shutdown → Inform the user if Firefox is still running after UI shutdown
It is related. If you think this RFE is better discussed in the other bug you can make it a duplicate.
I could not find something similar to this RFE.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407981
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.