Editing local xml file in vim and saving then refresh in ff3 causes Page Load Error

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
minor
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: eProdigy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

If I have an xml file loaded from my local file system in firefox 3 (in xml view mode), then open the file in vim and edit it - hit <esc>:w<enter> to save the file but leave vim open, then refresh the page in firefox 3 I get "Page Load Error" - File Not Found error.  I am unable to view the xml any more unless I back out to the parent directory and select the file again.  This is repeatable for me on each save in vim, but not with TextMate.  I am unable to try this on any other OS/Platform currently.

Reproducible: Always

Steps to Reproduce:
1. open xml file from local system (file:///Users/jherron/bugs/ff3/demo.xml)
2. validate that xml is displayed properly
3. open file in vim and edit, save file
4. refresh xml file in firefox
Actual Results:  
Page Load Error
----
File Not Found

      

      
      
      

      
        
        

          

Firefox can't find the file at /Users/jherron/bugs/ff3/demo.xml.

        


        
        

    * Could the item have been renamed, removed, or relocated?
    * Is there a spelling, capitalization, or other typographical error in the address?
    * Do you have sufficient access permissions to the requested item?

Expected Results:  
Xml file would have been refreshed, showing most recent changes

Using latest ff3 that was auto-updated on my system.  no extra themes or add-ons have been added by me personally.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.