css padding-top and padding-bottom do not render any results

RESOLVED DUPLICATE of bug 355505

Status

()

RESOLVED DUPLICATE of bug 355505
10 years ago
10 years ago

People

(Reporter: tezozo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

<head>
<style type="text/css">
<!--
.callout { border: solid blue 1px; background-color: cyan }
/* padding-top and padding-bottom do not work in mozilla */
.eccentricPadded {
    padding-top: 2px;
    padding-bottom: 8px;
    padding-left: 2px;
    padding-right: 16px;
    margin: 1px;
}
-->
</style>
</head>

<body>
<span class='callout'>
    <span class='eccentricPadded'>class eccentricPadded</span>
</span><br/>
<br/>
next line
</body>

Reproducible: Always

Steps to Reproduce:
1. copy the code in the details inside any .html file
2. open the file in Firefox 3.1
3. open the file in IE 6.0
Actual Results:  
The padding shows ok horizontally (padding-left, padding-right) but the vertical measures (padding-top, padding-bottom) do not. They do show perfectly on IE 6.0

Expected Results:  
The vertical padding should reflect as it does on IE 6.0

Updated

10 years ago
Component: General → Layout: Block and Inline
Product: Firefox → Core
QA Contact: general → layout.block-and-inline
Vertical padding, borders, and margins on inline elements do not affect line-height calculations.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355505
You need to log in before you can comment on or make changes to this bug.