Closed Bug 452613 Opened 12 years ago Closed 12 years ago

When dragging and dropping an image to a folder on the desktop in OSX, the folder then jumps to a different location

Categories

(Firefox :: Shell Integration, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 401380

People

(Reporter: bigearlx, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

I have Firefox set up so that it's not full-screen, but only occupies the center of the screen so that I can see items on my desktop and other apps around the edges without minimizing Firefox.  When I drag and drop an image out of a webpage displayed in Firefox into a folder on my desktop, the folder will then suddenly jump to a different location on my desktop.  This only happens with this most recent version of Firefox.  Severity-wise, it's on the line between "Minor" and "Normal" - it doesn't break any functionality per se, but it gets very annoying to have to minimize Firefox and put my folder back where it belongs every single time I drag an image file into it.

Reproducible: Always

Steps to Reproduce:
1.  Set up Firefox so that it's not fullscreen and position a folder in the area of the desktop not covered by the Firefox window.
2.  Bring up a webpage containing images.
3.  Drag and drop an image out of the webpage to the folder.
Actual Results:  
As soon as I let go of the mouse button to drop the image into the folder, the folder then disappears and immediately reappears in a different place on the desktop.

Expected Results:  
The folder should not move or otherwise do anything when a file is dropped into it.

No themes, addons or other customization on Firefox or my desktop; it's a pretty basic setup.
Hardware: PC → Macintosh
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401380
You need to log in before you can comment on or make changes to this bug.