No Address Book in today's Linux build.

VERIFIED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
critical
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Suresh, Assigned: chuang)

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+][nsbeta2+])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
1. Launch AB. There is no default AB's (Personal AB, Collected AB). Doesn't
matter whether it is a new profile or existing profile.

Build and platform:
2000-07-12-11-M17, Linux commercial build. (this is a respin build)
(Reporter)

Comment 1

18 years ago
Nominating for dogfood and nsbeta2, coz I cannot see the AB's. I hope everyone
uses AB. Updating Severity.
Severity: normal → critical
Keywords: dogfood, nsbeta2
QA Contact: lchiang → suresh
(Reporter)

Comment 2

18 years ago
It works fine on today's Mac and Windows commercial bits. 

Updated

18 years ago
Keywords: pp
Hardware: Other → PC
Summary: No Address Book in today's build. → No Address Book in today's Linux build.

Comment 3

18 years ago
reassigning to chuang.
Assignee: putterman → chuang
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 4

18 years ago
Putting on [dogfood+][nsbeta2+] radar. 
Whiteboard: [dogfood+][nsbeta2+]
(Assignee)

Comment 5

18 years ago
This is caused by the fix for bug 33980('Collected Addresses' being corrupted 
when saved to prefs.js).  It looks like nsIPref::GetLocalizedUnicharPref() 
return an empty string to me when getting the prefs from addressbook.properties  
on Linux.  I'm still looking.  

Comment 6

18 years ago
filenames are case sensitive on linux! it's addressBook.properties, not
addressbook.properties. Could that be it?

Comment 7

18 years ago
yep, that's it.
(Assignee)

Comment 8

18 years ago
Created attachment 11366 [details] [diff] [review]
The Patch file for the fix

Comment 9

18 years ago
r=alecf

Comment 10

18 years ago
I think that's the fastest trackdown-fix-review turnaround we've ever had! :)
(Assignee)

Comment 11

18 years ago
Thanks,  fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

18 years ago
Verified using 2000-07-17-08-M17 linux commercial build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.