Serious memory leak with firefox 3.0 on Windows XP Professional

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Brad, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1


I have Firefox 3.0 installed on 3 PCs at home... an old Windows XP Home machine with 512 Mb RAM, a Windows Vista Notebook, and an old Windows XP Professional machine... *only* on the Windows XP Professional machine do I experience a severe memory leak when running Firefox 3.0... it makes the machine quickly unusable as the working memory dwindles down to less than 10Mb and Firefox will start sucking up to 250Mb and more.  This can happy with several tabs or just a few... almost always, I have one tab open to Gmail.  



Reproducible: Always

Steps to Reproduce:
1.
2.
3.



This memory leak is making Firefox 3.0 unusable on my Windows XP Professional machine...  I have to use IE or Safari.

Comment 1

10 years ago
This bug report isn't specific enough to be useful.

* Gmail actually pulls down a lot of data from the server, and there's not much browsers can do about that.

* Memory use is complicated to debug.  For an overview of the scope of the issue, see http://blog.pavlov.net/2008/03/11/firefox-3-memory-usage/.

For memory use or memory leak bug reports to be useful, they need at least one of the following:

* Steps to reproduce that are specific enough that we can actually see the problem ourselves.  Since you have three computers, you might be able to figure out which Firefox extensions, Firefox settings, or usage patterns are responsible.

* Debugging output that clearly shows what objects are being leaked or held too long.  (See https://wiki.mozilla.org/Performance:Leak_Tools.)

If you can't do that, the most I can promise is to hunt down and fix at least one memory leak bug by September 15, which may or may not be the same bug you're hitting ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 2

10 years ago
> If you can't do that, the most I can promise is to hunt down and fix at least
> one memory leak bug by September 15, which may or may not be the same bug
> you're hitting ;)

Here's what I've got:

Bug 453146
I tried to debug it and didn't get very far.  But I managed to get the right developers looking at it, and they're working on fixing it.

Bug 427922
I started debugging it and got frustrated.  Then I found out Shawn had also looked and given up once, so I figured it was worth staring at some more.  I looked through the nsCStringArray code, hoping that something would look suspicious and turn out to be the cause of the leak.  I got lucky.  FIXED.

Bug 393802
I fixed it (partially) the way Boris had suggested a year earlier.

It's actually getting hard to find small leak bugs in Bugzilla.  Most of the known leaks are large (e.g. involving nsGlobalWindow or nsGenericElement), and I don't know how to debug those.  I asked David to try to make a screencast showing how to use DEBUG_CC to debug large leaks.

Comment 3

10 years ago
I have also memory leak.
My computer:
Core 2 Due
Ram 1GB
OS: Win 2000 prof
Running FireFox with these urls opened in its tabs:

http://msdn.microsoft.com/en-us/library/ms752059.aspx
http://wpf-graphics.com/Links.aspx
http://msdn.microsoft.com/en-us/library/ms746607.aspx
http://msdn.microsoft.com/en-us/library/ms752082.aspx
http://msdn.microsoft.com/en-us/library/ms747448.aspx
http://www.anim8or.com/main/index.html
http://www.devexpress.com/Downloads/NET/
http://www.devexpress.com/Help/?document=XtraEditors/CustomDocument620.htm
http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=7635018
http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=5659493
http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=7658360
http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=8108755
http://partnerproductsme.autodesk.com/catalog/default.asp
http://search.yahoo.com/search?p=normal+blood+pressure&ei=UTF-8&fr=moz2
http://www.nhlbi.nih.gov/hbp/detect/categ.htm
http://www.accu-chek.com/us/rewrite/content/en_US/3.7:15/article/ACCM_general_article_3230.htm
http://search.yahoo.com/search?p=accu-chek+go&ei=UTF-8&fr=moz2
http://search.yahoo.com/search?ei=UTF-8&fr=moz2&p=accu+chek+go+meter&rs=0&fr2=rs-top
http://www.roche.com.pk/go.html
http://www.accu-chek.com/us/rewrite/content/en_US/3.7.1:10/article/ACCM_general_article_3231.htm
http://search.yahoo.com/search;_ylt=A0geu50vXnxJsgAA.z1XNyoA?fr2=sg-gac&sado=1&p=heart%20beats%20per%20minute&fr=moz2&pqstr=Heart%20be
http://diabetes.about.com/od/symptomsdiagnosis/a/glucoselevels.htm
http://www.mybloodsugar.net/bloodsugarlevels.htm
http://www.revolutionhealth.com/conditions/diabetes/blood-sugar/?affiliate_code=lftm&msc=A63491
http://adam.about.com/encyclopedia/Glucose-test.htm
http://www.revolutionhealth.com/conditions/diabetes/treatments-medications/blood-glucose-monitoring/tips
http://en.wikipedia.org/wiki/Heart_rate
http://hypertextbook.com/facts/1998/PavelMatskevich.shtml
http://www.americanheart.org/presenter.jhtml?identifier=3034847
http://www.sharp.com/tools/heartrate.cfm
http://www.sharp.com/tools/ovulation.cfm

i left my computer for a night and came in the morning to see fireFox eating 660 MegaByte of RAM.

Updated

10 years ago
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.